summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-12-14 13:45:42 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-12-17 00:30:03 +0100
commit5c1d2c49a1f6ead6d9e64a48322b8cb4f8db2468 (patch)
tree32dbea5352dbe2a750655b627c090456cd53f880 /dev-php/pecl-mongodb
parentprofiles: tweak alpha target profiles to point to 17.0 profiles (diff)
downloadgentoo-5c1d2c49a1f6ead6d9e64a48322b8cb4f8db2468.tar.gz
gentoo-5c1d2c49a1f6ead6d9e64a48322b8cb4f8db2468.tar.bz2
gentoo-5c1d2c49a1f6ead6d9e64a48322b8cb4f8db2468.zip
dev-php/pecl-mongodb: skip failing test
Closes: https://bugs.gentoo.org/show_bug.cgi?id=670642 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/pecl-mongodb')
-rw-r--r--dev-php/pecl-mongodb/pecl-mongodb-1.5.2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-php/pecl-mongodb/pecl-mongodb-1.5.2.ebuild b/dev-php/pecl-mongodb/pecl-mongodb-1.5.2.ebuild
index 05c3b280e019..74d22474551a 100644
--- a/dev-php/pecl-mongodb/pecl-mongodb-1.5.2.ebuild
+++ b/dev-php/pecl-mongodb/pecl-mongodb-1.5.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -29,6 +29,13 @@ RDEPEND="
# pkgconfig needed if system libraries are used for bson and libmongoc
DEPEND="${RDEPEND} virtual/pkgconfig"
+src_prepare() {
+ # skip failing test (Bug #670642)
+ rm tests/exception/runtimeexception-haserrorlabel-002.phpt || die
+
+ php-ext-source-r3_src_prepare
+}
+
src_configure() {
local PHP_EXT_ECONF_ARGS=(
--enable-mongodb