summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-07-12 15:48:49 -0400
committerBrian Evans <grknight@gentoo.org>2016-07-12 15:48:49 -0400
commitde03399ccc489991bde7e8fa975d9d94f2e6befa (patch)
treec01a6e4e3909bd600720eeba468760e23a998f39 /dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.6.0_pre20141127.ebuild
parentdev-lang/ispc: version bump (diff)
downloadgentoo-de03399ccc489991bde7e8fa975d9d94f2e6befa.tar.gz
gentoo-de03399ccc489991bde7e8fa975d9d94f2e6befa.tar.bz2
gentoo-de03399ccc489991bde7e8fa975d9d94f2e6befa.zip
dev-php/pecl-mysqlnd_ms: Version bump; Drop php 5.4 USE
Bump to a VCS snapshot that can build on PHP 5.6 There are many intermediate changes which prevent a direct patch on 1.5.2 for PHP 5.6 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.6.0_pre20141127.ebuild')
-rw-r--r--dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.6.0_pre20141127.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.6.0_pre20141127.ebuild b/dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.6.0_pre20141127.ebuild
new file mode 100644
index 000000000000..1ac948d8fdf1
--- /dev/null
+++ b/dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.6.0_pre20141127.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME="mysqlnd_ms"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-5 php5-6"
+# This is an SVN snapshot stored locally
+SRC_URI="https://dev.gentoo.org/~grknight/distfiles/${P}.tar.xz"
+inherit php-ext-source-r3
+
+HOMEPAGE="http://pecl.php.net/package/mysqlnd_ms"
+KEYWORDS="~amd64"
+
+DESCRIPTION="A replication and load balancing plugin for the mysqlnd library"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+# Specifying targets due to USE flag transition
+DEPEND="
+ php_targets_php5-5? ( || (
+ dev-lang/php:5.5[-libmysqlclient,mysql]
+ dev-lang/php:5.5[-libmysqlclient,mysqli]
+ )
+ )
+ php_targets_php5-6? ( || (
+ dev-lang/php:5.6[-libmysqlclient,mysql]
+ dev-lang/php:5.6[-libmysqlclient,mysqli]
+ )
+ )
+"
+RDEPEND="${DEPEND}"