summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-08-14 10:59:31 -0400
committerBrian Evans <grknight@gentoo.org>2017-08-14 11:01:10 -0400
commit85bcfe89a3124ba35e2c02a5a1e1bc8b51e49678 (patch)
tree5a8e8a84d42adb21013ece1894ef82bea5c2134f /dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
parentdev-php/pecl-taint: Version bump for 2.0.4 (diff)
downloadgentoo-85bcfe89a3124ba35e2c02a5a1e1bc8b51e49678.tar.gz
gentoo-85bcfe89a3124ba35e2c02a5a1e1bc8b51e49678.tar.bz2
gentoo-85bcfe89a3124ba35e2c02a5a1e1bc8b51e49678.zip
dev-php/pecl-ps: Version bump for 1.4.1
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-php/pecl-ps/pecl-ps-1.4.1.ebuild')
-rw-r--r--dev-php/pecl-ps/pecl-ps-1.4.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild b/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
new file mode 100644
index 000000000000..86ad145c8f78
--- /dev/null
+++ b/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="ps"
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+# Only really build for >=7.0
+USE_PHP="php7-0 php7-1 php7-2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="PHP extension for creating PostScript files"
+LICENSE="BSD"
+SLOT="7"
+IUSE="examples"
+
+DEPEND="
+ php_targets_php7-0? ( dev-libs/pslib )
+ php_targets_php7-1? ( dev-libs/pslib )
+ php_targets_php7-2? ( dev-libs/pslib )
+"
+RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-ps:0[php_targets_php5-6] )"
+PHP_EXT_ECONF_ARGS=""
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_target_php7-1 || use php_targets_php7-2 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_target_php7-1 || use php_targets_php7-2 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}