summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-05-09 09:50:42 -0400
committerBrian Evans <grknight@gentoo.org>2018-05-09 09:51:56 -0400
commit10ae79efbda13f69e017e54d833a1c6f4f8a6ea4 (patch)
tree33896b030911cb7f23cac323bc9f62edd8ac8432 /dev-php/pecl-redis/pecl-redis-4.0.2.ebuild
parentdev-php/pecl-propro: Drop old revision (diff)
downloadgentoo-10ae79efbda13f69e017e54d833a1c6f4f8a6ea4.tar.gz
gentoo-10ae79efbda13f69e017e54d833a1c6f4f8a6ea4.tar.bz2
gentoo-10ae79efbda13f69e017e54d833a1c6f4f8a6ea4.zip
dev-php/pecl-redis: Version bump for 4.0.2
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-php/pecl-redis/pecl-redis-4.0.2.ebuild')
-rw-r--r--dev-php/pecl-redis/pecl-redis-4.0.2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-php/pecl-redis/pecl-redis-4.0.2.ebuild b/dev-php/pecl-redis/pecl-redis-4.0.2.ebuild
new file mode 100644
index 000000000000..7c75c710c648
--- /dev/null
+++ b/dev-php/pecl-redis/pecl-redis-4.0.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="redis"
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+DOCS=( arrays.markdown cluster.markdown README.markdown CREDITS )
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="PHP extension for interfacing with Redis"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="igbinary +session"
+
+DEPEND="
+ php_targets_php5-6? ( dev-lang/php:5.6[session?] igbinary? ( dev-php/igbinary[php_targets_php5-6] ) )
+ php_targets_php7-0? ( dev-lang/php:7.0[session?] igbinary? ( dev-php/igbinary[php_targets_php7-0] ) )
+ php_targets_php7-1? ( dev-lang/php:7.1[session?] igbinary? ( dev-php/igbinary[php_targets_php7-1] ) )
+ php_targets_php7-2? ( dev-lang/php:7.2[session?] igbinary? ( dev-php/igbinary[php_targets_php7-2] ) )
+"
+RDEPEND="${DEPEND} !dev-php/pecl-redis:7"
+
+# The test suite requires network access.
+RESTRICT=test
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-redis
+ $(use_enable igbinary redis-igbinary)
+ $(use_enable session redis-session)
+ )
+ php-ext-source-r3_src_configure
+}
+
+src_test(){
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ # Run tests for Redis class
+ ${PHPCLI} -d extension=modules/redis.so \
+ tests/TestRedis.php \
+ --class Redis \
+ --host ${PECL_REDIS_HOST} || die 'test suite failed'
+ done
+}
+
+pkg_postinst() {
+ elog "The 4.0 release comes with breaking API changes."
+ elog "Be sure to verify any applications upon upgrading."
+}