summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-17 21:53:56 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-17 22:01:31 +0100
commitd4e4fa46ce4ead45fb662e3b3685045e4f877988 (patch)
tree9d87813931aabf401069fee2e5f989a1904575ac /dev-php/pecl-redis/pecl-redis-5.1.1.ebuild
parentdev-php/pecl-raphf: bump to v2.0.1 (diff)
downloadgentoo-d4e4fa46ce4ead45fb662e3b3685045e4f877988.tar.gz
gentoo-d4e4fa46ce4ead45fb662e3b3685045e4f877988.tar.bz2
gentoo-d4e4fa46ce4ead45fb662e3b3685045e4f877988.zip
dev-php/pecl-redis: bump to v5.1.1
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/pecl-redis/pecl-redis-5.1.1.ebuild')
-rw-r--r--dev-php/pecl-redis/pecl-redis-5.1.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-php/pecl-redis/pecl-redis-5.1.1.ebuild b/dev-php/pecl-redis/pecl-redis-5.1.1.ebuild
new file mode 100644
index 000000000000..61a6320308de
--- /dev/null
+++ b/dev-php/pecl-redis/pecl-redis-5.1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PHP_EXT_NAME="redis"
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
+PHP_EXT_NEEDED_USE="json?,session?"
+DOCS=( arrays.markdown cluster.markdown README.markdown CREDITS )
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="PHP extension for interfacing with Redis"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="igbinary +json +session"
+
+DEPEND="
+ igbinary? ( dev-php/igbinary[php_targets_php7-1?,php_targets_php7-2?,php_targets_php7-3?,php_targets_php7-4?] )
+"
+RDEPEND="${DEPEND} !dev-php/pecl-redis:7"
+
+# The test suite requires network access.
+RESTRICT=test
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-redis
+ $(use_enable igbinary redis-igbinary)
+ $(use_enable json redis-json)
+ $(use_enable session redis-session)
+ )
+ php-ext-source-r3_src_configure
+}
+
+src_test(){
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ # Run tests for Redis class
+ ${PHPCLI} -d extension=modules/redis.so \
+ tests/TestRedis.php \
+ --class Redis \
+ --host ${PECL_REDIS_HOST} || die 'test suite failed'
+ done
+}