summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-10-15 16:06:42 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-10-15 16:33:00 +0200
commit22e135eb4ed9f1e902c677501e2f6003f57e5f58 (patch)
tree54d06eb5bd9c3bc287fbd9d19582c706e9f29c93 /dev-php/pecl-rrd
parentdev-php/pecl-uploadprogress: bump to v2.0.2 (diff)
downloadgentoo-22e135eb4ed9f1e902c677501e2f6003f57e5f58.tar.gz
gentoo-22e135eb4ed9f1e902c677501e2f6003f57e5f58.tar.bz2
gentoo-22e135eb4ed9f1e902c677501e2f6003f57e5f58.zip
dev-php/pecl-rrd: bump to v2.0.3
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/pecl-rrd')
-rw-r--r--dev-php/pecl-rrd/Manifest1
-rw-r--r--dev-php/pecl-rrd/pecl-rrd-2.0.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-php/pecl-rrd/Manifest b/dev-php/pecl-rrd/Manifest
index 3f9af491a776..30056a01f5e4 100644
--- a/dev-php/pecl-rrd/Manifest
+++ b/dev-php/pecl-rrd/Manifest
@@ -1 +1,2 @@
DIST rrd-2.0.1.tgz 18880 BLAKE2B c3fb65e95aece39690085830ec1c43ba173e173591215d6a66145ac71079f8d5ba5b097acd9018c86d2342550001334f8e1c98e22204d94a24aee5cc086295ca SHA512 b6f7173f54fcf49bf014cc6c78263c169cdf53dac66c12f5f88db7e01b49ea74da84a55f61deb25c866e6e2e74275ec48fc4a3d1b46719f66b5b7b7eb000b6b3
+DIST rrd-2.0.3.tgz 19178 BLAKE2B 473fe53e858665372133db9f13d9aeac330da2ca57a8fb59f0eb280f1bdd40d2f0b28179a9b150acdf15d7bbc6fb5416a82dcd670c67ad39050cbd1c5795b62e SHA512 28679ccead54806d1e92accc6f5ebab582a41db802f95797ddb43e3e15690889be3437f22e2a14939d217422ac2700ef90ae0a9b36244ddead3856343b3e09b4
diff --git a/dev-php/pecl-rrd/pecl-rrd-2.0.3.ebuild b/dev-php/pecl-rrd/pecl-rrd-2.0.3.ebuild
new file mode 100644
index 000000000000..034811552435
--- /dev/null
+++ b/dev-php/pecl-rrd/pecl-rrd-2.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+USE_PHP="php7-3 php7-4 php8-0"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="RRDtool bindings for PHP"
+LICENSE="BSD"
+SLOT="7"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="net-analyzer/rrdtool[graph(-)]"
+RDEPEND="${DEPEND}"
+
+#PATCHES=( "${FILESDIR}/${PV}" )
+PHP_EXT_ECONF_ARGS=()
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ # Prepare test data
+ emake -C tests/data all
+ NO_INTERACTION="yes" emake test
+ done
+}