summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-04-08 15:15:21 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-04-08 15:27:24 -0400
commit06902785bbdd836806ec9fa021fcb078996a5b76 (patch)
treeeb1a75490e9b7b07e1d66d71d75a512e569082c3 /dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
parentprofiles: Fix typo in license_groups. (diff)
downloadgentoo-06902785bbdd836806ec9fa021fcb078996a5b76.tar.gz
gentoo-06902785bbdd836806ec9fa021fcb078996a5b76.tar.bz2
gentoo-06902785bbdd836806ec9fa021fcb078996a5b76.zip
dev-php/pecl-ssh2: add php-7.1 support.
Gentoo-Bug: 603508 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild')
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
index 1e571c0de962..ee9effc3e76a 100644
--- a/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
+++ b/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
@@ -1,18 +1,16 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PHP_EXT_NAME="ssh2"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-USE_PHP="php7-0 php5-6"
+USE_PHP="php5-6 php7-0 php7-1"
EGIT_REPO_URI="https://git.php.net/repository/pecl/networking/ssh2.git"
inherit php-ext-source-r3 git-r3
-USE_PHP="php7-0"
+USE_PHP="php7-0 php7-1"
DESCRIPTION="PHP bindings for the libssh2 library"
LICENSE="PHP-3.01"
@@ -20,9 +18,9 @@ SLOT="7"
IUSE=""
KEYWORDS=""
DEPEND=">=net-libs/libssh2-1.2"
-RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-ssh2:0[php_targets_php5-6] )"
+RDEPEND="${DEPEND}
+ php_targets_php5-6? ( dev-php/pecl-ssh2:0[php_targets_php5-6] )"
HOMEPAGE="https://pecl.php.net/package/ssh2"
-PHP_EXT_ECONF_ARGS=""
src_unpack() {
git-r3_src_unpack
@@ -30,7 +28,7 @@ src_unpack() {
}
src_prepare() {
- if use php_targets_php7-0 ; then
+ if use php_targets_php7-0 || use php_targets_php7-1 ; then
php-ext-source-r3_src_prepare
else
default_src_prepare