summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-02 23:57:50 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-03 00:03:40 -0500
commitc9face083ba534f37d02a1c4d76c6337fef4c911 (patch)
tree2e7725b8ebb3963061fef24f22cc291b0737aa6e /dev-php/pecl-stomp/pecl-stomp-2.0.0-r1.ebuild
parentsys-block/open-isns: fixing ossl-1.1 build issue bug 604454 (diff)
downloadgentoo-c9face083ba534f37d02a1c4d76c6337fef4c911.tar.gz
gentoo-c9face083ba534f37d02a1c4d76c6337fef4c911.tar.bz2
gentoo-c9face083ba534f37d02a1c4d76c6337fef4c911.zip
dev-php/pecl-stomp: new revisions fixing the no-ssl build.
The main reason for these two new revisions are to fix what happens when USE="-ssl" is set. The build system expects --with-openssl-dir=no in that case, so the existing --without-openssl-dir was causing it to crash. That should now be fixed; I've used "usex" instead of "use_with". Some other minor fixes were made: * The LICENSE for this package is PHP-3.01, not PHP-3. * The "ssl" flag was also defaulted to being on, which -- unless critical -- kind of defeats the purpose of USE flags. It now defaults to being off. * Two eclass variables that were set to their default values have been removed. * The test suite is now enabled, but only for v2.0.0 where it actually passes (even though failure doesn't kill the build?). Gentoo-Bug: 603560 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php/pecl-stomp/pecl-stomp-2.0.0-r1.ebuild')
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-2.0.0-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-php/pecl-stomp/pecl-stomp-2.0.0-r1.ebuild b/dev-php/pecl-stomp/pecl-stomp-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..a64f473dceb7
--- /dev/null
+++ b/dev-php/pecl-stomp/pecl-stomp-2.0.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+USE_PHP="php5-6 php7-0"
+PHP_EXT_NAME="stomp"
+DOCS=( CREDITS doc/classes.php doc/functions.php )
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php7-0"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension to communicate with Stomp message brokers"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE="examples ssl test"
+
+DEPEND="${DEPEND}
+ php_targets_php7-0? ( dev-lang/php:7.0[ssl?] )
+"
+
+RDEPEND="${DEPEND}
+ php_targets_php5-6? ( dev-php/pecl-stomp:0 )"
+
+src_prepare() {
+ if use php_targets_php7-0 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-stomp
+ --with-openssl-dir=$(usex ssl "${EPREFIX}/usr")
+ )
+ php-ext-source-r3_src_configure
+}
+
+src_install() {
+ if use php_targets_php7-0 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}