summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-06-07 14:55:34 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-06-07 16:07:57 +0200
commit5eca691ea3bd543916e7e78c27622fc04c43030e (patch)
treedc482b08638e8e5bb98b3376e389b5a95aa053e8 /dev-php/pecl-zmq/pecl-zmq-1.1.3-r2.ebuild
parentdev-php/libvirt-php: add PHP 7.3 support (diff)
downloadgentoo-5eca691ea3bd543916e7e78c27622fc04c43030e.tar.gz
gentoo-5eca691ea3bd543916e7e78c27622fc04c43030e.tar.bz2
gentoo-5eca691ea3bd543916e7e78c27622fc04c43030e.zip
dev-php/pecl-zmq: add PHP 7.3 support
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/pecl-zmq/pecl-zmq-1.1.3-r2.ebuild')
-rw-r--r--dev-php/pecl-zmq/pecl-zmq-1.1.3-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-php/pecl-zmq/pecl-zmq-1.1.3-r2.ebuild b/dev-php/pecl-zmq/pecl-zmq-1.1.3-r2.ebuild
new file mode 100644
index 000000000000..32a8fed8aad3
--- /dev/null
+++ b/dev-php/pecl-zmq/pecl-zmq-1.1.3-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP Bindings for ZeroMQ messaging"
+LICENSE="BSD"
+SLOT="0"
+IUSE="czmq"
+
+RDEPEND="net-libs/zeromq czmq? ( <net-libs/czmq-3 )"
+DEPEND="${RDEPEND} virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-php7-3-compatibility.patch )
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=( $(use_with czmq) )
+ php-ext-source-r3_src_configure
+}