summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-02-22 15:35:57 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-02-22 15:35:57 +0100
commitd00233a99c1410d1972cdfcba58353fa16a8c5fe (patch)
tree90aa879165e1fe7364fedcb792c45d925701ae74 /dev-php/phar-io-manifest/phar-io-manifest-1.0.3.ebuild
parentdev-php/PEAR-Net_IPv4: bump to v1.3.5 (diff)
downloadgentoo-d00233a99c1410d1972cdfcba58353fa16a8c5fe.tar.gz
gentoo-d00233a99c1410d1972cdfcba58353fa16a8c5fe.tar.bz2
gentoo-d00233a99c1410d1972cdfcba58353fa16a8c5fe.zip
dev-php/phar-io-manifest: bump to v1.0.3
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/phar-io-manifest/phar-io-manifest-1.0.3.ebuild')
-rw-r--r--dev-php/phar-io-manifest/phar-io-manifest-1.0.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/phar-io-manifest/phar-io-manifest-1.0.3.ebuild b/dev-php/phar-io-manifest/phar-io-manifest-1.0.3.ebuild
new file mode 100644
index 000000000000..c50a6a0feca8
--- /dev/null
+++ b/dev-php/phar-io-manifest/phar-io-manifest-1.0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Reading phar.io manifest information from a PHP Archive (PHAR)"
+HOMEPAGE="https://github.com/phar-io/manifest"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="examples"
+
+S="${WORKDIR}/manifest-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ dev-php/phar-io-version
+ dev-lang/php:*[phar]"
+
+src_install() {
+ insinto /usr/share/php/PharIo/Manifest
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+ dodoc README.md
+ use examples && dodoc -r examples
+}