summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-03-09 10:41:41 -0500
committerBrian Evans <grknight@gentoo.org>2017-03-09 11:22:26 -0500
commita7100386fb4ccd88c2fbe9a6df4004596bfcb1fe (patch)
tree7e5f6c1d67d89b103d42e8ace2f8236c78879b99 /dev-php/phpspec-prophecy
parentdev-php/myclabs-deepcopy: New package for an unbundled phpunit (diff)
downloadgentoo-a7100386fb4ccd88c2fbe9a6df4004596bfcb1fe.tar.gz
gentoo-a7100386fb4ccd88c2fbe9a6df4004596bfcb1fe.tar.bz2
gentoo-a7100386fb4ccd88c2fbe9a6df4004596bfcb1fe.zip
dev-php/phpspec-prophecy: New package for an unbundled phpunit
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-php/phpspec-prophecy')
-rw-r--r--dev-php/phpspec-prophecy/Manifest1
-rw-r--r--dev-php/phpspec-prophecy/files/autoload.php15
-rw-r--r--dev-php/phpspec-prophecy/metadata.xml8
-rw-r--r--dev-php/phpspec-prophecy/phpspec-prophecy-1.7.0.ebuild31
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-php/phpspec-prophecy/Manifest b/dev-php/phpspec-prophecy/Manifest
new file mode 100644
index 000000000000..4c45b19e5b8f
--- /dev/null
+++ b/dev-php/phpspec-prophecy/Manifest
@@ -0,0 +1 @@
+DIST phpspec-prophecy-1.7.0.tar.gz 60338 SHA256 7825f7b942fc9887fa0311ab84fcca3ddb6b99ab8405995a3783e00165944c20 SHA512 e8efb3882d869f10fe39dff7c2185e1ec6f044c794fd6a5785e1c1c69c71b91dc3997f61bd2566d3243dde0becce568beba9a18fa0fd152e6ce74ca43a9a0fb0 WHIRLPOOL bb540116eaa5f42f7792a0b5df5469973ee1bc99105c0145bc9d6d00f8710c2a468b53400b9650adbb0cca739e75e98e82ba5dc41c2cb5b5df7e4a0911115dd7
diff --git a/dev-php/phpspec-prophecy/files/autoload.php b/dev-php/phpspec-prophecy/files/autoload.php
new file mode 100644
index 000000000000..eb61ccb5eedb
--- /dev/null
+++ b/dev-php/phpspec-prophecy/files/autoload.php
@@ -0,0 +1,15 @@
+<?php
+/* Autoloader for dev-php/phpspec-prophecy */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+Fedora\Autoloader\Autoload::addPsr0('Prophecy\\', __DIR__);
+
+\Fedora\Autoloader\Dependencies::required(array(
+ '/usr/share/php/phpDocumentor/ReflectionDocBlock/autoload.php',
+ '/usr/share/php/SebastianBergmann/Comparator/autoload.php',
+ '/usr/share/php/Doctrine/Instantiator/autoload.php',
+ '/usr/share/php/SebastianBergmann/RecursionContext/autoload.php',
+));
diff --git a/dev-php/phpspec-prophecy/metadata.xml b/dev-php/phpspec-prophecy/metadata.xml
new file mode 100644
index 000000000000..b86acf66c756
--- /dev/null
+++ b/dev-php/phpspec-prophecy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-php/phpspec-prophecy/phpspec-prophecy-1.7.0.ebuild b/dev-php/phpspec-prophecy/phpspec-prophecy-1.7.0.ebuild
new file mode 100644
index 000000000000..f6f7abc6d37e
--- /dev/null
+++ b/dev-php/phpspec-prophecy/phpspec-prophecy-1.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="prophecy"
+MY_VENDOR="phpspec"
+
+DESCRIPTION="Highly opinionated mocking framework"
+HOMEPAGE="https://github.com/${MY_VENDOR}/${MY_PN}"
+SRC_URI="https://github.com/${MY_VENDOR}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ <dev-php/doctrine-instantiator-2
+ <dev-php/phpdocumentor-reflection-docblock-4
+ <dev-php/sebastian-comparator-3
+ <dev-php/sebastian-recursion-context-4
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/${MY_VENDOR}/Prophecy
+ doins -r src/Prophecy/*
+ doins "${FILESDIR}/autoload.php"
+}