summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-05-03 10:00:09 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-05-03 10:21:26 -0400
commit7ed24384c15ebf3341039ee8953da37310c314ce (patch)
treeb3d98ea4b2ef380843e4adff6bb125b1be281c14 /dev-php/phpunit
parentmail-client/thunderbird: bump to 52.1.0 (diff)
downloadgentoo-7ed24384c15ebf3341039ee8953da37310c314ce.tar.gz
gentoo-7ed24384c15ebf3341039ee8953da37310c314ce.tar.bz2
gentoo-7ed24384c15ebf3341039ee8953da37310c314ce.zip
dev-php/phpunit: new revision to fix missing autoload dependency.
The sebastian-object-enumerator package is one of PHPUnit's dependencies and is listed in RDEPEND, but it was missing from the autoloader. This was causing test failures in packages that use the PHPUnit classes directly, but is easily fixed by adding another line to autoload.php. I've made a revision to ensure that users get the new autoload.php before we try to run any test suites. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-php/phpunit')
-rw-r--r--dev-php/phpunit/files/autoload.php37
-rw-r--r--dev-php/phpunit/phpunit-5.7.15-r1.ebuild (renamed from dev-php/phpunit/phpunit-5.7.15.ebuild)0
2 files changed, 20 insertions, 17 deletions
diff --git a/dev-php/phpunit/files/autoload.php b/dev-php/phpunit/files/autoload.php
index 69ffa07bab95..f33b4c8881a1 100644
--- a/dev-php/phpunit/files/autoload.php
+++ b/dev-php/phpunit/files/autoload.php
@@ -1,8 +1,10 @@
<?php
/* Autoloader for dev-php/phpunit and its dependencies */
+$include_dir = '/usr/share/php';
+
if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
- require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+ require_once "${include_dir}/Fedora/Autoloader/autoload.php";
}
\Fedora\Autoloader\Autoload::addClassMap(
@@ -144,24 +146,25 @@ if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
'phpunit_util_type' => '/Util/Type.php',
'phpunit_util_xml' => '/Util/XML.php',
),
- '/usr/share/php/PHPUnit'
+ "${include_dir}/PHPUnit"
);
// Dependencies
\Fedora\Autoloader\Dependencies::required(array(
- '/usr/share/php/File/Iterator/autoload.php',
- '/usr/share/php/PHP/CodeCoverage/autoload.php',
- '/usr/share/php/PHP/Timer/autoload.php',
- '/usr/share/php/SebastianBergmann/Version/autoload.php',
- '/usr/share/php/SebastianBergmann/Diff/autoload.php',
- '/usr/share/php/SebastianBergmann/Environment/autoload.php',
- '/usr/share/php/SebastianBergmann/Exporter/autoload.php',
- '/usr/share/php/SebastianBergmann/GlobalState/autoload.php',
- '/usr/share/php/SebastianBergmann/Comparator/autoload.php',
- '/usr/share/php/SebastianBergmann/ResourceOperations/autoload.php',
- '/usr/share/php/Symfony/Component/Yaml/autoload.php',
- '/usr/share/php/Text/Template/autoload.php',
- '/usr/share/php/myclabs/DeepCopy/autoload.php',
- '/usr/share/php/PHPUnit/Framework/MockObject/autoload.php',
- '/usr/share/php/phpspec/Prophecy/autoload.php',
+ "${include_dir}/File/Iterator/autoload.php",
+ "${include_dir}/PHP/CodeCoverage/autoload.php",
+ "${include_dir}/PHP/Timer/autoload.php",
+ "${include_dir}/SebastianBergmann/Version/autoload.php",
+ "${include_dir}/SebastianBergmann/Diff/autoload.php",
+ "${include_dir}/SebastianBergmann/Environment/autoload.php",
+ "${include_dir}/SebastianBergmann/Exporter/autoload.php",
+ "${include_dir}/SebastianBergmann/GlobalState/autoload.php",
+ "${include_dir}/SebastianBergmann/Comparator/autoload.php",
+ "${include_dir}/SebastianBergmann/ObjectEnumerator/autoload.php",
+ "${include_dir}/SebastianBergmann/ResourceOperations/autoload.php",
+ "${include_dir}/Symfony/Component/Yaml/autoload.php",
+ "${include_dir}/Text/Template/autoload.php",
+ "${include_dir}/myclabs/DeepCopy/autoload.php",
+ "${include_dir}/PHPUnit/Framework/MockObject/autoload.php",
+ "${include_dir}/phpspec/Prophecy/autoload.php",
));
diff --git a/dev-php/phpunit/phpunit-5.7.15.ebuild b/dev-php/phpunit/phpunit-5.7.15-r1.ebuild
index 2672b9d632ae..2672b9d632ae 100644
--- a/dev-php/phpunit/phpunit-5.7.15.ebuild
+++ b/dev-php/phpunit/phpunit-5.7.15-r1.ebuild