summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-12-19 16:23:05 -0500
committerBrian Evans <grknight@gentoo.org>2019-12-19 16:50:54 -0500
commit456a4c8ae4615031627abf3d211a833b492ea282 (patch)
treeb91f320c9e9cff1b51151827622ee50fb4249094 /dev-php/sebastian-comparator/sebastian-comparator-3.0.2.ebuild
parentdev-php/sebastian-exporter: Version bump for 3.1.2 (diff)
downloadgentoo-456a4c8ae4615031627abf3d211a833b492ea282.tar.gz
gentoo-456a4c8ae4615031627abf3d211a833b492ea282.tar.bz2
gentoo-456a4c8ae4615031627abf3d211a833b492ea282.zip
dev-php/sebastian-comparator: Version bump for 3.0.2
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/sebastian-comparator/sebastian-comparator-3.0.2.ebuild')
-rw-r--r--dev-php/sebastian-comparator/sebastian-comparator-3.0.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-php/sebastian-comparator/sebastian-comparator-3.0.2.ebuild b/dev-php/sebastian-comparator/sebastian-comparator-3.0.2.ebuild
new file mode 100644
index 000000000000..cb5336b6e085
--- /dev/null
+++ b/dev-php/sebastian-comparator/sebastian-comparator-3.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Compare PHP values for equality"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-php/sebastian-diff-3.0
+ <dev-php/sebastian-diff-4.0
+ >=dev-php/sebastian-exporter-3.1
+ <dev-php/sebastian-exporter-4.0
+ >=dev-lang/php-7.1:*
+"
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/Comparator
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}