summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-12-19 16:06:19 -0500
committerBrian Evans <grknight@gentoo.org>2019-12-19 16:50:53 -0500
commitfbc48c7a1f220fd5accb7f6bd02a1b17b56d3186 (patch)
tree8decf94b668905fe2c6450bc0801e7a05d2645cd /dev-php/sebastian-diff/sebastian-diff-3.0.2.ebuild
parentdev-php/myclabs-deepcopy: Version bump for 1.9.4 (diff)
downloadgentoo-fbc48c7a1f220fd5accb7f6bd02a1b17b56d3186.tar.gz
gentoo-fbc48c7a1f220fd5accb7f6bd02a1b17b56d3186.tar.bz2
gentoo-fbc48c7a1f220fd5accb7f6bd02a1b17b56d3186.zip
dev-php/sebastian-diff: Version bump for 3.0.2
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/sebastian-diff/sebastian-diff-3.0.2.ebuild')
-rw-r--r--dev-php/sebastian-diff/sebastian-diff-3.0.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/sebastian-diff/sebastian-diff-3.0.2.ebuild b/dev-php/sebastian-diff/sebastian-diff-3.0.2.ebuild
new file mode 100644
index 000000000000..20aa53030521
--- /dev/null
+++ b/dev-php/sebastian-diff/sebastian-diff-3.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="diff"
+
+DESCRIPTION="PHP Diff implementation"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.1:*"
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/Diff
+ doins -r src/*
+ newins "${FILESDIR}/autoload-3.0.2.php" autoload.php
+}