summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-12-19 16:19:08 -0500
committerBrian Evans <grknight@gentoo.org>2019-12-19 16:50:54 -0500
commit0461f41f6f199c79c6ee61e7fd0de8865546647b (patch)
treecddf7f1b4e03cca58b6246758d6f10fbb9611560 /dev-php/sebastian-exporter/sebastian-exporter-3.1.2.ebuild
parentdev-php/sebastian-recursion-context: Version bump for 3.0.0 (diff)
downloadgentoo-0461f41f6f199c79c6ee61e7fd0de8865546647b.tar.gz
gentoo-0461f41f6f199c79c6ee61e7fd0de8865546647b.tar.bz2
gentoo-0461f41f6f199c79c6ee61e7fd0de8865546647b.zip
dev-php/sebastian-exporter: Version bump for 3.1.2
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/sebastian-exporter/sebastian-exporter-3.1.2.ebuild')
-rw-r--r--dev-php/sebastian-exporter/sebastian-exporter-3.1.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/sebastian-exporter/sebastian-exporter-3.1.2.ebuild b/dev-php/sebastian-exporter/sebastian-exporter-3.1.2.ebuild
new file mode 100644
index 000000000000..380721a6128a
--- /dev/null
+++ b/dev-php/sebastian-exporter/sebastian-exporter-3.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Export PHP variables for visualization"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ =dev-php/sebastian-recursion-context-3*
+ =dev-lang/php-7*:*"
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/Exporter
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}