summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-12-20 09:16:10 -0500
committerBrian Evans <grknight@gentoo.org>2019-12-20 13:34:21 -0500
commitebaa22e55a08fa6dcaa75e5ec755f82e231c6357 (patch)
tree21f98a3b61466d031cc36475a806db4eab097639 /dev-php/sebastian-resource-operations/sebastian-resource-operations-2.0.1.ebuild
parentdev-php/sebastian-object-enumerator: Version bump for 3.0.3 (diff)
downloadgentoo-ebaa22e55a08fa6dcaa75e5ec755f82e231c6357.tar.gz
gentoo-ebaa22e55a08fa6dcaa75e5ec755f82e231c6357.tar.bz2
gentoo-ebaa22e55a08fa6dcaa75e5ec755f82e231c6357.zip
dev-php/sebastian-resource-operations: Version bump for 2.0.1
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/sebastian-resource-operations/sebastian-resource-operations-2.0.1.ebuild')
-rw-r--r--dev-php/sebastian-resource-operations/sebastian-resource-operations-2.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/sebastian-resource-operations/sebastian-resource-operations-2.0.1.ebuild b/dev-php/sebastian-resource-operations/sebastian-resource-operations-2.0.1.ebuild
new file mode 100644
index 000000000000..68a1a80abaca
--- /dev/null
+++ b/dev-php/sebastian-resource-operations/sebastian-resource-operations-2.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Provides a list of PHP built-in functions that operate on resources"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.1:*
+ "
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/ResourceOperations
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}