summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-12-07 16:18:02 -0500
committerBrian Evans <grknight@gentoo.org>2016-12-07 16:49:32 -0500
commit621c8a48ea5225699bb2368866b4ffa3ecf0be19 (patch)
tree41bd7d161923a5d550f8c51f33f2103e33726f47 /dev-php/suhosin
parentdev-php/pecl-yaz: Drop old (diff)
downloadgentoo-621c8a48ea5225699bb2368866b4ffa3ecf0be19.tar.gz
gentoo-621c8a48ea5225699bb2368866b4ffa3ecf0be19.tar.bz2
gentoo-621c8a48ea5225699bb2368866b4ffa3ecf0be19.zip
dev-php/suhosin: Drop old revision
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-php/suhosin')
-rw-r--r--dev-php/suhosin/suhosin-0.9.38.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-php/suhosin/suhosin-0.9.38.ebuild b/dev-php/suhosin/suhosin-0.9.38.ebuild
deleted file mode 100644
index 9f0b7e021744..000000000000
--- a/dev-php/suhosin/suhosin-0.9.38.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-PHP_EXT_NAME="suhosin"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-USE_PHP="php5-6 php5-5 php5-4"
-
-inherit php-ext-source-r2
-
-KEYWORDS="alpha amd64 arm hppa ia64 ~ppc ppc64 ~s390 ~sh sparc x86"
-
-DESCRIPTION="Suhosin is an advanced protection system for PHP installations"
-HOMEPAGE="http://www.suhosin.org/"
-SRC_URI="http://download.suhosin.org/${P}.tar.gz"
-LICENSE="PHP-3.01"
-SLOT="0"
-IUSE=""
-
-for target in ${USE_PHP}; do
- slot=${target/php}
- slot=${slot/-/.}
- PHPUSEDEPEND="${PHPUSEDEPEND}
- php_targets_${target}? ( dev-lang/php:${slot}[unicode] )"
-done
-
-DEPEND="${PHPUSEDEPEND}"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env ${slot}
- epatch "${FILESDIR}"/${P}-libcrypt.patch
- done
- php-ext-source-r2_src_prepare
-}
-
-src_install() {
- php-ext-source-r2_src_install
- dodoc CREDITS
-
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env ${slot}
- for inifile in ${PHPINIFILELIST} ; do
- insinto "${inifile/${PHP_EXT_NAME}.ini/}"
- insopts -m644
- doins "suhosin.ini"
- done
- done
-}
-
-src_test() {
- # Makefile passes a hard-coded -d extension_dir=./modules, we move the lib
- # away from there in src_compile
- for slot in `php_get_slots`; do
- php_init_slot_env ${slot}
- NO_INTERACTION="yes" emake test || die "emake test failed for slot ${slot}"
- done
-}