summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-29 20:30:21 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-29 20:31:52 +0100
commit9ab0a699c1f15f81e7dfd9270031fb39c6126916 (patch)
treec01af2c51cc04f2d9ff2c323f712d71bbee35be8 /dev-php/swoole-async
parentdev-php/swoole: bump to v4.4.12 (diff)
downloadgentoo-9ab0a699c1f15f81e7dfd9270031fb39c6126916.tar.gz
gentoo-9ab0a699c1f15f81e7dfd9270031fb39c6126916.tar.bz2
gentoo-9ab0a699c1f15f81e7dfd9270031fb39c6126916.zip
dev-php/swoole-async: initial import of v4.4.12
Bug: https://bugs.gentoo.org/697690 Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/swoole-async')
-rw-r--r--dev-php/swoole-async/Manifest1
-rw-r--r--dev-php/swoole-async/metadata.xml8
-rw-r--r--dev-php/swoole-async/swoole-async-4.4.12.ebuild51
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-php/swoole-async/Manifest b/dev-php/swoole-async/Manifest
new file mode 100644
index 000000000000..9ef8b7fab79a
--- /dev/null
+++ b/dev-php/swoole-async/Manifest
@@ -0,0 +1 @@
+DIST swoole-async-4.4.12.tar.gz 417674 BLAKE2B 77a96f53b1b159b558eb4759fe172e4a3b8f2648cd9f49252d89508eb56b4d342b178fa3c84d6a425c300a286063b4d32a05d09a3da4f3769be4c25a9800783c SHA512 adfb761803e5ec93c30aa2a4bbc312a2f43287a54cd237c0a87237dfcbfe1e6daa3d57ec2cdf15720202aa9a7830ed67ab2efdf2f7dd81989c3693e91bc22143
diff --git a/dev-php/swoole-async/metadata.xml b/dev-php/swoole-async/metadata.xml
new file mode 100644
index 000000000000..d355171f926f
--- /dev/null
+++ b/dev-php/swoole-async/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-php/swoole-async/swoole-async-4.4.12.ebuild b/dev-php/swoole-async/swoole-async-4.4.12.ebuild
new file mode 100644
index 000000000000..845bfc568cc0
--- /dev/null
+++ b/dev-php/swoole-async/swoole-async-4.4.12.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="swoole_async"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_SAPIS="cli"
+DOCS=( README.md )
+
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
+
+inherit php-ext-pecl-r3
+
+SRC_URI="https://github.com/swoole/ext-async/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ext-async-${PV}"
+PHP_EXT_S="${S}"
+
+HOMEPAGE="https://www.swoole.co.uk"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="An extension of Swoole, including the async callback style API"
+LICENSE="Apache-2.0"
+SLOT="0"
+# Tests will require pre-configured endpoint
+RESTRICT="test"
+
+DEPEND=">=dev-php/swoole-4.3"
+
+RDEPEND="${DEPEND}"
+
+IUSE="debug"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-swoole_async
+ $(use_enable debug)
+ )
+
+ php-ext-source-r3_src_configure
+}
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ [[ -f tests/template.phpt ]] && rm tests/template.phpt
+ SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
+ done
+}