summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-12-18 16:47:12 -0500
committerMichael Orlitzky <mjo@gentoo.org>2016-12-18 18:17:18 -0500
commite92eddae65cba5726b0b6d5dfcf5a91ed36952cf (patch)
treee0df7d678a8481f631fcd9536f7d31b9e2ff2adf /dev-php/symfony-console/symfony-console-2.7.9-r1.ebuild
parentdev-php/symfony-console: add upstream/remote-id tag to metadata.xml. (diff)
downloadgentoo-e92eddae65cba5726b0b6d5dfcf5a91ed36952cf.tar.gz
gentoo-e92eddae65cba5726b0b6d5dfcf5a91ed36952cf.tar.bz2
gentoo-e92eddae65cba5726b0b6d5dfcf5a91ed36952cf.zip
dev-php/symfony-console: loosen restrictions on dependencies.
Three of this package's dependencies were declared with the tilde "~" operator. Per discussion with the maintainer, these are probably better off being "newer than" operators. We retain the lower bound set by upstream. Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php/symfony-console/symfony-console-2.7.9-r1.ebuild')
-rw-r--r--dev-php/symfony-console/symfony-console-2.7.9-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/symfony-console/symfony-console-2.7.9-r1.ebuild b/dev-php/symfony-console/symfony-console-2.7.9-r1.ebuild
new file mode 100644
index 000000000000..00cad8652ca7
--- /dev/null
+++ b/dev-php/symfony-console/symfony-console-2.7.9-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Subtree split of the Symfony Console Component"
+HOMEPAGE="https://github.com/symfony/console"
+SRC_URI="https://github.com/symfony/console/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader
+ >=dev-php/psr-log-1.0.2
+ >=dev-php/symfony-event-dispatcher-2.1.0
+ >=dev-php/symfony-process-2.8.12"
+
+S="${WORKDIR}/console-${PV}"
+
+src_install() {
+ insinto "/usr/share/php/Symfony/Component/Console"
+ doins -r . "${FILESDIR}"/autoload.php
+ dodoc README.md
+}