summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Levitsky <kitsunenokenja@protonmail.ch>2018-01-08 17:22:01 -0500
committerMichael Orlitzky <mjo@gentoo.org>2018-01-28 11:45:48 -0500
commit7b8481c35ca54a8148512fe4436ba55c3936fb68 (patch)
tree77e15c80ba8c4912f950463ecd177d9964fbdf59 /dev-php/theseer-tokenizer/theseer-tokenizer-1.1.0.ebuild
parentprofiles/package.mask: cleanup (diff)
downloadgentoo-7b8481c35ca54a8148512fe4436ba55c3936fb68.tar.gz
gentoo-7b8481c35ca54a8148512fe4436ba55c3936fb68.tar.bz2
gentoo-7b8481c35ca54a8148512fe4436ba55c3936fb68.zip
dev-php/theseer-tokenizer: new package
Package-Manager: Portage-2.3.13, Repoman-2.3.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php/theseer-tokenizer/theseer-tokenizer-1.1.0.ebuild')
-rw-r--r--dev-php/theseer-tokenizer/theseer-tokenizer-1.1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.0.ebuild b/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.0.ebuild
new file mode 100644
index 000000000000..f4435fb25f39
--- /dev/null
+++ b/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="tokenizer"
+
+DESCRIPTION="Library for converting tokenized PHP source code into XML and other formats"
+HOMEPAGE="https://github.com/theseer/tokenizer"
+SRC_URI="https://github.com/theseer/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.0:*[tokenizer,xmlwriter]"
+
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+src_prepare() {
+ cp "${FILESDIR}/autoload.php" src/ || die
+ default
+}
+
+src_install() {
+ insinto /usr/share/php/TheSeer/Tokenizer
+ doins -r src/*
+ dodoc README.md
+}
+
+src_test() {
+ phpunit || die "Unit testing failed!"
+}