summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/xcache
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/xcache')
-rw-r--r--dev-php/xcache/Manifest3
-rw-r--r--dev-php/xcache/metadata.xml5
-rw-r--r--dev-php/xcache/xcache-3.0.4.ebuild59
-rw-r--r--dev-php/xcache/xcache-3.1.2.ebuild60
-rw-r--r--dev-php/xcache/xcache-3.2.0.ebuild60
5 files changed, 187 insertions, 0 deletions
diff --git a/dev-php/xcache/Manifest b/dev-php/xcache/Manifest
new file mode 100644
index 000000000000..1f5a5fadf231
--- /dev/null
+++ b/dev-php/xcache/Manifest
@@ -0,0 +1,3 @@
+DIST xcache-3.0.4.tar.bz2 142844 SHA256 447baab727b6b0d2955e10ce117f55d9a63d306def78c34837b4ff3d6c586a4e SHA512 99c7756e100ff844e8e995a1909e0bb66330631f208ac28b5008f172c19a98cd3e126481c6a8f35cff70d3360902ddd799a5aa6fb0148a2d3b462a52ca7e1fa0 WHIRLPOOL 2a2153f8e3240b6bca6287939f6bec3a4e1a539b81383d0f298944da4014c5b7c5be15e6f354c798f30c3a74d0b5ba49ea72b8185f89a8e2a0349f2f8a84df1a
+DIST xcache-3.1.2.tar.bz2 146408 SHA256 84cf9b38710c51aabd28987632999cae99f7869d4cb056752ed901a262fef98f SHA512 1ed32b5e781d2bcf32e15481b6277657701b1a0cb1f8ef96852cbe1f0c8621c1ffaa550920cb06b93f9f51b31d18bcfc49c477defcf558fea167a8eab4266b2a WHIRLPOOL e697552aad67d9a270cb5dc2628c8f47e99311ac787226c76c4044191c21e15797ce79341f8b39ef3ba5680fb8dc26ccd74e42d1a3fb44926c74b566cd3cea6f
+DIST xcache-3.2.0.tar.bz2 148392 SHA256 7d12a3cbd5f729b70f9226ac19406d11219f1c5f5e82b3bbb43ea9460cbf6cbd SHA512 9d7bec73ac941c8e38b2cda15af65044291adc0806b39586048943515d67656d64871bea4ea05b3dff76761ebed462db2d6ad0e489079291abc55313b1508946 WHIRLPOOL 37eb83618f896037f7ca6f5a65e113c468b4ee03bf05421ee5f6907a1ad562f5794267970531eba4798ec517915ac9debde36f1d8dcabfe442ae75f1de5b0841
diff --git a/dev-php/xcache/metadata.xml b/dev-php/xcache/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/xcache/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/xcache/xcache-3.0.4.ebuild b/dev-php/xcache/xcache-3.0.4.ebuild
new file mode 100644
index 000000000000..701e15d261cd
--- /dev/null
+++ b/dev-php/xcache/xcache-3.0.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="xcache"
+PHP_EXT_INI="yes"
+PHPSAPILIST="apache2 cgi fpm"
+USE_PHP="php5-4"
+
+inherit php-ext-source-r2 confutils
+
+DESCRIPTION="A fast and stable PHP opcode cacher"
+HOMEPAGE="http://xcache.lighttpd.net/"
+SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# make test would just run php's test and as such need the full php source
+RESTRICT="test"
+
+DEPEND="
+ !dev-php/eaccelerator
+ !dev-php/pecl-apc
+ virtual/httpd-php
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+
+ my_conf="--enable-xcache=shared \
+ --enable-xcache-constant \
+ --enable-xcache-optimizer \
+ --enable-xcache-coverager \
+ --enable-xcache-assembler \
+ --enable-xcache-encoder \
+ --enable-xcache-decoder"
+
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ php-ext-source-r2_src_install
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins lib/Decompiler.class.php
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins -r htdocs
+}
+
+pkg_postinst() {
+ elog "lib/Decompiler.class.php, and the htdocs/ directory shipped with this"
+ elog "release were installed into ${PHP_EXT_SHARED_DIR}."
+}
diff --git a/dev-php/xcache/xcache-3.1.2.ebuild b/dev-php/xcache/xcache-3.1.2.ebuild
new file mode 100644
index 000000000000..e98818354c78
--- /dev/null
+++ b/dev-php/xcache/xcache-3.1.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="xcache"
+PHP_EXT_INI="yes"
+PHPSAPILIST="apache2 cgi fpm"
+USE_PHP="php5-4 php5-5"
+
+inherit php-ext-source-r2 confutils
+
+DESCRIPTION="A fast and stable PHP opcode cacher"
+HOMEPAGE="http://xcache.lighttpd.net/"
+SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# make test would just run php's test and as such need the full php source
+RESTRICT="test"
+
+DEPEND="
+ !dev-php/eaccelerator
+ !dev-php/pecl-apc
+ virtual/httpd-php
+ php_targets_php5-5? ( !dev-lang/php:5.5[opcache] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+
+ my_conf="--enable-xcache=shared \
+ --enable-xcache-constant \
+ --enable-xcache-optimizer \
+ --enable-xcache-coverager \
+ --enable-xcache-assembler \
+ --enable-xcache-encoder \
+ --enable-xcache-decoder"
+
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ php-ext-source-r2_src_install
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins lib/Decompiler.class.php
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins -r htdocs
+}
+
+pkg_postinst() {
+ elog "lib/Decompiler.class.php, and the htdocs/ directory shipped with this"
+ elog "release were installed into ${PHP_EXT_SHARED_DIR}."
+}
diff --git a/dev-php/xcache/xcache-3.2.0.ebuild b/dev-php/xcache/xcache-3.2.0.ebuild
new file mode 100644
index 000000000000..6ad537bdcb15
--- /dev/null
+++ b/dev-php/xcache/xcache-3.2.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="xcache"
+PHP_EXT_INI="yes"
+PHPSAPILIST="apache2 cgi fpm"
+USE_PHP="php5-4 php5-5 php5-6"
+
+inherit php-ext-source-r2 confutils
+
+DESCRIPTION="A fast and stable PHP opcode cacher"
+HOMEPAGE="http://xcache.lighttpd.net/"
+SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# make test would just run php's test and as such need the full php source
+RESTRICT="test"
+
+DEPEND="
+ !dev-php/eaccelerator
+ !dev-php/pecl-apc
+ virtual/httpd-php
+ php_targets_php5-5? ( !dev-lang/php:5.5[opcache] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+
+ my_conf="--enable-xcache=shared \
+ --enable-xcache-constant \
+ --enable-xcache-optimizer \
+ --enable-xcache-coverager \
+ --enable-xcache-assembler \
+ --enable-xcache-encoder \
+ --enable-xcache-decoder"
+
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ php-ext-source-r2_src_install
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins lib/Decompiler.class.php
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins -r htdocs
+}
+
+pkg_postinst() {
+ elog "lib/Decompiler.class.php, and the htdocs/ directory shipped with this"
+ elog "release were installed into ${PHP_EXT_SHARED_DIR}."
+}