summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/xdebug/xdebug-2.3.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/xdebug/xdebug-2.3.1.ebuild')
-rw-r--r--dev-php/xdebug/xdebug-2.3.1.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/dev-php/xdebug/xdebug-2.3.1.ebuild b/dev-php/xdebug/xdebug-2.3.1.ebuild
new file mode 100644
index 000000000000..7ae3a31ead9e
--- /dev/null
+++ b/dev-php/xdebug/xdebug-2.3.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+inherit php-ext-source-r2
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="A PHP debugging and profiling extension"
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ ~dev-php/xdebug-client-${PV}"
+
+src_install() {
+ dodoc NEWS README CREDITS
+ php-ext-source-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "xdebug.auto_trace" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_output_name" '"trace.%c"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_format" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_options" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_includes" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_params" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_return" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_vars" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.default_enable" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.extended_info" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
+ php-ext-source-r2_addtoinifiles "xdebug.max_nesting_level" '"100"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_exception_trace" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_local_vars" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_mem_delta" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.ENV" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.FILES" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.GET" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.POST" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_globals" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_once" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_undefined" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_enable" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_output_name" '"cachegrind.out.%p"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_append" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_aggregate" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_enable" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_handler" '"dbgp"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_host" '"localhost"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_mode" '"req"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_port" '"9000"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_autostart" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_log" '""'
+ php-ext-source-r2_addtoinifiles "xdebug.idekey" '""'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_data" '"512"'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_depth" '"2"'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_children" '"128"'
+
+}
+
+pkg_postinst() {
+ ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
+ ewarn "installed as a dependency, and not all users will want xdebug to be"
+ ewarn "enabled by default. If you want to enable it, you should edit the"
+ ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
+ ewarn "call xdebug_enable() in your code."
+}