summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-12-08 12:25:45 -0500
committerBrian Evans <grknight@gentoo.org>2016-12-08 13:28:25 -0500
commit0be6f781fb8598cbdbef85ca5b56030c89d2a0a6 (patch)
treef76be37bb66fab7053fa0ecbab8cc350be4625ee /dev-php/xdebug/xdebug-2.5.0.ebuild
parentdev-php/xdebug-client: Version bump (diff)
downloadgentoo-0be6f781fb8598cbdbef85ca5b56030c89d2a0a6.tar.gz
gentoo-0be6f781fb8598cbdbef85ca5b56030c89d2a0a6.tar.bz2
gentoo-0be6f781fb8598cbdbef85ca5b56030c89d2a0a6.zip
dev-php/xdebug: Version bump
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-php/xdebug/xdebug-2.5.0.ebuild')
-rw-r--r--dev-php/xdebug/xdebug-2.5.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/xdebug/xdebug-2.5.0.ebuild b/dev-php/xdebug/xdebug-2.5.0.ebuild
new file mode 100644
index 000000000000..89e8e797f19f
--- /dev/null
+++ b/dev-php/xdebug/xdebug-2.5.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+PHP_EXT_INIFILE="2.4.1-xdebug.ini"
+
+USE_PHP="php7-1 php7-0 php5-6"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="A PHP debugging and profiling extension"
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ ~dev-php/xdebug-client-${PV}"
+DOCS=( README.rst CREDITS )
+PHP_EXT_ECONF_ARGS=()
+
+pkg_postinst() {
+ ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
+ ewarn "installed as a dependency, and not all users will want xdebug to be"
+ ewarn "enabled by default. If you want to enable it, you should edit the"
+ ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
+ ewarn "call xdebug_enable() in your code."
+}