summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-06-15 01:16:12 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-06-15 01:30:24 +0200
commitd220cd88d0f72f0436b3f240aec20add06ba245c (patch)
tree0a25d22223a695c617607f4e7b16f36ea2b5f9ae /dev-php/xdebug/xdebug-2.9.6.ebuild
parentdev-php/xdebug-client: bump to v2.9.6 (diff)
downloadgentoo-d220cd88d0f72f0436b3f240aec20add06ba245c.tar.gz
gentoo-d220cd88d0f72f0436b3f240aec20add06ba245c.tar.bz2
gentoo-d220cd88d0f72f0436b3f240aec20add06ba245c.zip
dev-php/xdebug: bump to v2.9.6
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/xdebug/xdebug-2.9.6.ebuild')
-rw-r--r--dev-php/xdebug/xdebug-2.9.6.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-php/xdebug/xdebug-2.9.6.ebuild b/dev-php/xdebug/xdebug-2.9.6.ebuild
new file mode 100644
index 000000000000..95745e2c779d
--- /dev/null
+++ b/dev-php/xdebug/xdebug-2.9.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+PHP_EXT_INIFILE="2.6.0-xdebug.ini"
+
+USE_PHP="php7-2 php7-3 php7-4"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="A PHP debugging and profiling extension"
+HOMEPAGE="https://xdebug.org/"
+# Using tarball from GitHub for tests
+#SRC_URI="https://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+SRC_URI="https://github.com/xdebug/xdebug/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ ~dev-php/xdebug-client-${PV}"
+DOCS=( README.rst CREDITS )
+PHP_EXT_ECONF_ARGS=()
+
+pkg_postinst() {
+ ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
+ ewarn "installed as a dependency, and not all users will want xdebug to be"
+ ewarn "enabled by default. If you want to enable it, you should edit the"
+ ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
+ ewarn "call xdebug_enable() in your code."
+}