summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-06-10 09:30:43 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-06-10 09:45:39 -0400
commit02e9960b449b8af4440ffa2bb40030962d9dc5a1 (patch)
tree0c6b28200a090ab6bdcfedaa333529b0e93ce268 /dev-php
parentmedia-sound/lilypond: fixed fontforge dependency use flag (diff)
downloadgentoo-02e9960b449b8af4440ffa2bb40030962d9dc5a1.tar.gz
gentoo-02e9960b449b8af4440ffa2bb40030962d9dc5a1.tar.bz2
gentoo-02e9960b449b8af4440ffa2bb40030962d9dc5a1.zip
dev-php/PHPMailer: new version 6.1.6 to fix CVE-2020-13625.
Bug: https://bugs.gentoo.org/727584 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PHPMailer/Manifest1
-rw-r--r--dev-php/PHPMailer/PHPMailer-6.1.6.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-php/PHPMailer/Manifest b/dev-php/PHPMailer/Manifest
index d6699fcd8b8b..6e985eedf796 100644
--- a/dev-php/PHPMailer/Manifest
+++ b/dev-php/PHPMailer/Manifest
@@ -5,3 +5,4 @@ DIST PHPMailer-6.1.2.tar.gz 93635 BLAKE2B f8a12415a0e24697c84de06782f78a1cc37785
DIST PHPMailer-6.1.3.tar.gz 93690 BLAKE2B 08f653520a2b7819470cbb5cf1f43480cdcab51fe452f4831df47269f4223cfeb7016e41e8de75c11b15a04fa278fe08439f3c022af9088a5c8f5e4259ae7ebb SHA512 195155e49b29740422e75d7dbcf082cf8b26c87dad7b5473b9d55267e31af3847cb65a1c79f73225fa79080428d8c7516f5cd4d083824fa42f3b22a3bec8c34e
DIST PHPMailer-6.1.4.tar.gz 93915 BLAKE2B 9f4ec584c57d70c4cbbc33c4ba85469579a00ebbf4aa4680b6f965ad37339b923386e371c01b673bca8c0de6f6ed123b6a1456541b1c472c6f0c93592c7c9e96 SHA512 f13cb959d89c64392ecff4cceaa650c80310f854aaff1c09144727aeb7f50c7ebeaaf7a2be488fa796b5acd1c42c4d13204b0410bc579d2e6aec98feee3b21ef
DIST PHPMailer-6.1.5.tar.gz 94435 BLAKE2B 8c4f515af8260d20524636be6c89a3d6a8824691037d956141a2822163d1e59676c0dcf96683b0e4434e94ffb3f57235afc758840920156a7aa664290ad04b65 SHA512 a741dd4fa585619892cc1d8b4ce35fee7c1f5f44d946b368e1a363eff77e5afe1553ac295db49c6110131561c1124b1dc184c9a405fb1652e7aeab9d7b0323a8
+DIST PHPMailer-6.1.6.tar.gz 94769 BLAKE2B 6689f4429c0847de41016325553d58d544f78d5f8a94d9014841435a3cf161e4e10b14fe2cbb61c737bf75d87f2dc4cde66885c06a0b6992a472f0f46fe5dd6b SHA512 25530e6c5513e89729a5b253565143a5a9a35ee5f7813637eee18ca1d604cb83625f7beb106e56536f681d7ec4332fcd3cddcac5da7c73f730db1b056ba5b2e4
diff --git a/dev-php/PHPMailer/PHPMailer-6.1.6.ebuild b/dev-php/PHPMailer/PHPMailer-6.1.6.ebuild
new file mode 100644
index 000000000000..e27c5fd93328
--- /dev/null
+++ b/dev-php/PHPMailer/PHPMailer-6.1.6.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Full-featured email creation and transfer class for PHP"
+HOMEPAGE="https://github.com/PHPMailer/PHPMailer"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# To help out the Composer children, the tests and examples are missing
+# from the release tarballs.
+IUSE="doc idn ssl"
+
+# The ctype and filter extensions get used unconditionally, with no
+# fallback and no "extension missing" exception. All of the other
+# extensions are technically optional, depending on how you use
+# PHPMailer and whether or not you're willing to settle for fallback
+# implementations.
+#
+# The insane dependency string is to prevent the ctype and filter
+# extensions from being provided by one version (i.e. slot) of PHP,
+# while intl and unicode are provided by another.
+RDEPEND="
+ ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,ssl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter,ssl] )
+ )
+ !ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter] )
+ )"
+BDEPEND="doc? ( dev-php/phpDocumentor )"
+
+src_prepare() {
+ # OAuth.php relies on a (now non-nonexistent) autoloader. We remove
+ # it early so that we don't generate documentation for it later on.
+ rm src/OAuth.php || die 'failed to remove src/OAuth.php'
+ eapply_user
+}
+
+src_compile() {
+ if use doc; then
+ phpdoc --filename="src/*.php" \
+ --target="./html" \
+ --cache-folder="${T}" \
+ --title="${PN}" \
+ --sourcecode \
+ --force \
+ --progressbar \
+ || die "failed to generate API documentation"
+ fi
+}
+
+src_install() {
+ # The PHPMailer class loads its language files
+ # using a relative path, so we need to keep the "src" here.
+ insinto "/usr/share/php/${PN}"
+ doins -r language src
+
+ dodoc README.md SECURITY.md
+ use doc && dodoc -r html/*
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "Upstream no longer provides an autoloader, so you will need"
+ elog "to include each source file (for example: PHPMailer.php,"
+ elog "Exception.php,...) that you need."
+}