summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-05-17 19:28:04 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-05-17 19:28:04 -0400
commit18834a17deb847788ac32a80f9ddaa2cff861560 (patch)
treee531eae6161a3efed9d242e14cad06e0aca88ec5 /dev-php
parentnet-print/cups-filters: add note re c++11 (diff)
downloadgentoo-18834a17deb847788ac32a80f9ddaa2cff861560.tar.gz
gentoo-18834a17deb847788ac32a80f9ddaa2cff861560.tar.bz2
gentoo-18834a17deb847788ac32a80f9ddaa2cff861560.zip
dev-php/smarty: add upstream v4.1.1 with a fix for CVE-2022-29221.
Bug: https://bugs.gentoo.org/845180 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/smarty/Manifest1
-rw-r--r--dev-php/smarty/smarty-4.1.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-php/smarty/Manifest b/dev-php/smarty/Manifest
index 1af0ed132b60..d129d6ccfbb6 100644
--- a/dev-php/smarty/Manifest
+++ b/dev-php/smarty/Manifest
@@ -1,2 +1,3 @@
DIST manual-en.3.1.14.zip 408414 BLAKE2B 03d4e7a386eb3bd5b19e5c555ec34b86812838a5b5fac8ec0ab9701fba89a5867714da57d950f68224a89bbe2267c18d638ee850681860de309c74bbfb3d0a0b SHA512 d384e3856b45ed3f992f3732a5465120abe9fb947cdf13ff67a9c4264f72987d24885ee61cd7309b728e64cdfe4f34c3e7f757096d35de56d962f3b78def9e58
DIST smarty-4.0.4.tar.gz 359012 BLAKE2B 84f34ff1e00f81de8961e252a14a7d813180b789820ace363c7a64f05d57c874d1f77068aed43d1d4cfc9aed0b348625e85e75a30ae3f1dab7a15c92f6ed9ab5 SHA512 1eef2585b415905e4a67328ab56ae473e5121b8f3a50f0d3aa3c60ab331eda9137744c92dcf2fcc674a6ec68eb714aa60468d1b56a436a94778be242fbd0b377
+DIST smarty-4.1.1.tar.gz 235624 BLAKE2B c624812ebebb1a8d09a5d80e2826b4e0e90310f6f53f903c9e962542b41b5c150ede1031f66c290e4dc2bb336eb532fd3305a3d97c7e43768d45f57df6815448 SHA512 93e601959651a00bdf9be9c9ddcfea6b189f70270ec8ab4764d2759c0c4de07c74a79cf4e42ee97d16c246130d6f1da5c8601fa60e5194906fe3b416934d1ef5
diff --git a/dev-php/smarty/smarty-4.1.1.ebuild b/dev-php/smarty/smarty-4.1.1.ebuild
new file mode 100644
index 000000000000..b8594fc0e25c
--- /dev/null
+++ b/dev-php/smarty/smarty-4.1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOC_PV="3.1.14"
+
+DESCRIPTION="A template engine for PHP"
+HOMEPAGE="https://www.smarty.net/"
+SRC_URI="https://github.com/smarty-php/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( https://www.smarty.net/files/docs/manual-en.${DOC_PV}.zip )"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+BDEPEND="doc? ( app-arch/unzip )"
+
+# PHP unicode support is detected at runtime, and the cached templates
+# that smarty generates depend on it. If, later on, PHP is reinstalled
+# without unicode support, all of the previously-generated cached
+# templates will begin to throw 500 errrors for missing mb_foo
+# functions. See bug #532618.
+RDEPEND="dev-lang/php:*[unicode]"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r libs/*
+
+ local DOCS=( CHANGELOG.md README.md SECURITY.md )
+ local HTML_DOCS
+ use doc && HTML_DOCS="${WORKDIR}/manual-en/"*
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog
+ elog 'To use it in your scripts, include the Smarty.class.php file'
+ elog "from the \"${PN}\" directory; for example,"
+ elog
+ elog " require('${PN}/Smarty.class.php');"
+ elog
+ elog 'After that, the Smarty class will be available to you.'
+}