summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-10-09 00:44:40 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-10-09 00:53:16 +0200
commit2218b051d4ab89d51b384fe3cb6c07fad54a07fa (patch)
tree4dd54b3dd7017332c29fa3d4b14e27eecec82a9d /dev-php
parentdev-php/igbinary: bump to v3.1.6 (diff)
downloadgentoo-2218b051d4ab89d51b384fe3cb6c07fad54a07fa.tar.gz
gentoo-2218b051d4ab89d51b384fe3cb6c07fad54a07fa.tar.bz2
gentoo-2218b051d4ab89d51b384fe3cb6c07fad54a07fa.zip
dev-php/pecl-uuid: bump to v1.2.0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-uuid/Manifest1
-rw-r--r--dev-php/pecl-uuid/pecl-uuid-1.2.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/pecl-uuid/Manifest b/dev-php/pecl-uuid/Manifest
index aa6a6b42dcb5..294dd034e156 100644
--- a/dev-php/pecl-uuid/Manifest
+++ b/dev-php/pecl-uuid/Manifest
@@ -1 +1,2 @@
DIST uuid-1.1.0.tgz 15225 BLAKE2B 0a5a326076707e0d3e7c779151a13853e52d026ebdf62c9ab147cf5d00bbc68a3d82e15101c1d4a232d96ea7e988304a25517723adb3127938474172dfab16c2 SHA512 aea814a12e266e4a9e36c58bae78927fa9de6d2b7bf9c75a911710b26958aeecd31d972f56519cf4882a4b13864bc0740ad968b06e704ce7642279253009e76d
+DIST uuid-1.2.0.tgz 16270 BLAKE2B a3746dce1c27973247fd84ccdf8d73809fae775fa0cf133c3bf09c862d93c6c3a53f2d093a1df3dd8bab90f4e58c326e6e7944bfdf436723c79ad5b634e46e18 SHA512 bd557823a8c2b78f74675a2554445eafc69193c6fe5af1f9435cdd90a8efdec0d3974ae8af759fe7d30b2f805876fc2ef55058dea245c9d89a792f634fdb0a10
diff --git a/dev-php/pecl-uuid/pecl-uuid-1.2.0.ebuild b/dev-php/pecl-uuid/pecl-uuid-1.2.0.ebuild
new file mode 100644
index 000000000000..f030569d725f
--- /dev/null
+++ b/dev-php/pecl-uuid/pecl-uuid-1.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="uuid"
+PHP_EXT_INIT="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( CREDITS )
+
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="A wrapper around libuuid"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="sys-apps/util-linux"
+RDEPEND="${DEPEND}"
+PHP_EXT_ECONF_ARGS=()