summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-02-20 13:45:36 -0500
committerBrian Evans <grknight@gentoo.org>2018-02-20 14:28:50 -0500
commit2e7e9b91102abc178b6ef1153a4c2d851699dae0 (patch)
tree6292acde2e4c333f4f905e284c5517cc09a32acd /dev-php
parentdev-php/phing: Drop old (diff)
downloadgentoo-2e7e9b91102abc178b6ef1153a4c2d851699dae0.tar.gz
gentoo-2e7e9b91102abc178b6ef1153a4c2d851699dae0.tar.bz2
gentoo-2e7e9b91102abc178b6ef1153a4c2d851699dae0.zip
dev-php/phpDocumentor: Version bump to 2.9.0
Includes php 7 syntax support Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/phpDocumentor/Manifest1
-rw-r--r--dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/phpDocumentor/Manifest b/dev-php/phpDocumentor/Manifest
index f17c77767eb2..b7f085e8fa02 100644
--- a/dev-php/phpDocumentor/Manifest
+++ b/dev-php/phpDocumentor/Manifest
@@ -1,2 +1,3 @@
DIST phpDocumentor-2.7.0.tgz 16118916 BLAKE2B de8538d7b45b1d266fa3dfafcea7d9d6ff91972419aeea334058bf9655f98cfc9ee8ba3a3205f4f939dea462b54c9c30425ec80172a394498b3da2c4d230a72a SHA512 068f2470f73ea6940077c23f5565e737d6065e881b9d1456fc617b00c285cc2358773afc16e97e3d9403b5caaaa32a9dcd360bfc91decf349f4b100fee4a9129
DIST phpDocumentor-2.8.2.phar 33079646 BLAKE2B cb66562a6417cb9015f432be221cfaf4e7c577301e3cbdcf09a2f1add7e42ddc2fd6cda91c4a78a8a41f9ceebc60bcffe3bccb8b12077be565b2f6529cff1d78 SHA512 ef47483147358d423595d6c771971481b99338adeed0f2742ab6856925d3a1d501d4e786aab75cba5dc2306728aef6bf8fc4cfd8ea35d5d9c903f1afa5695c2a
+DIST phpDocumentor-2.9.0.phar 18276081 BLAKE2B 988d9ae15a369c94d6dd83d68b64054d4d1829d651ae28a5082913ebd47666a73f5e48d331c09561777b58c6716707f4751b047e1aad9545d83ac9c964933b80 SHA512 62efc492d387675f753094bf4c42f890808bc3f45ae4a6908a519722af11ffbda41b47100e68f12e5b73a2eaa49fe8afc8143c751518a2a68b10afa18f896f10
diff --git a/dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild b/dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild
new file mode 100644
index 000000000000..dac43364c339
--- /dev/null
+++ b/dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Automatic documenting of php api directly from the source"
+HOMEPAGE="http://phpdoc.org"
+SRC_URI="https://github.com/${PN}/${PN}2/releases/download/v${PV}/${PN}.phar -> ${P}.phar"
+
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# block old version that provides the same binary
+DEPEND="!dev-php/PEAR-PhpDocumentor"
+RDEPEND="media-gfx/graphviz
+ dev-lang/php:*[cli,iconv,intl,phar,xmlreader,xslt]"
+S="${WORKDIR}"
+
+src_unpack() { :; }
+
+src_install() {
+ exeinto /usr/share/php/${PN}
+ newexe "${DISTDIR}/${P}.phar" ${PN}.phar
+ dosym "../share/php/${PN}/${PN}.phar" /usr/bin/phpdoc
+}