summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-11-05 18:42:42 -0400
committerBrian Evans <grknight@gentoo.org>2022-11-05 18:42:42 -0400
commit36a571a3c53b01f7299002c6cb64ce300116150c (patch)
treef4a655047b4372ef73e05f5cea4db6557b97dcb2 /dev-php
parentdev-php/snuffleupagus: Version bump for 0.8.3 (diff)
downloadgentoo-36a571a3c53b01f7299002c6cb64ce300116150c.tar.gz
gentoo-36a571a3c53b01f7299002c6cb64ce300116150c.tar.bz2
gentoo-36a571a3c53b01f7299002c6cb64ce300116150c.zip
dev-php/snuffleupagus: Drop old
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/snuffleupagus/Manifest1
-rw-r--r--dev-php/snuffleupagus/snuffleupagus-0.7.1-r1.ebuild74
2 files changed, 0 insertions, 75 deletions
diff --git a/dev-php/snuffleupagus/Manifest b/dev-php/snuffleupagus/Manifest
index ac8092978a6c..af5d6f90c9d0 100644
--- a/dev-php/snuffleupagus/Manifest
+++ b/dev-php/snuffleupagus/Manifest
@@ -1,2 +1 @@
-DIST snuffleupagus-0.7.1.tar.gz 11962220 BLAKE2B 8504721ca08e727a5a6fa58c216a5dac7be3fe6e5a98cffcb17e44a2235628c26f02afd2159e9b1fbe8e40e26bc7c4e34a4ff027ee27b8ec29cf89865dbb8514 SHA512 21510e214f94dd50a4aa05226188c9433a6a261c0bd3d58973ed4536754b3e12356e3f625480c370b66c570482694c25d336a771fbbbeb27e1d524b1f82c7869
DIST snuffleupagus-0.8.3.tar.gz 11987086 BLAKE2B 989dbb57a8375cb394dfb41f07de5c048b66936a8e5b3dd14fb3609149dd371203f7a30d1fbcfe8ef6faa2ba5864c68b209b1b209541c348c0277c8bd12b568a SHA512 426ab7509e31f712dbef1505bf60f00d3a31481de1fbb0b438e45fb45a50fbdc16204d6af18490c5522a41e62d83107f280a20ac2ffc2795da68407b0dac81d6
diff --git a/dev-php/snuffleupagus/snuffleupagus-0.7.1-r1.ebuild b/dev-php/snuffleupagus/snuffleupagus-0.7.1-r1.ebuild
deleted file mode 100644
index d18383730d41..000000000000
--- a/dev-php/snuffleupagus/snuffleupagus-0.7.1-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PHP_EXT_NAME="${PN}"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-PHP_EXT_ECONF_ARGS=( --enable-${PN} )
-PHP_EXT_S="${S}/src"
-
-USE_PHP="php7-4 php8-0"
-
-inherit php-ext-source-r3
-
-KEYWORDS="~amd64"
-
-DESCRIPTION="A PHP module to drastically raise the cost of attacks against websites"
-HOMEPAGE="https://snuffleupagus.readthedocs.io/index.html"
-SRC_URI="https://github.com/jvoisin/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3 PHP-3.01"
-SLOT="0"
-
-src_prepare() {
- # fix file locations tests look for
- ln -s "${P}/config" "${WORKDIR}/config" || die
- # Fix path dependent tests
- sed -i -e 's~src/tests/~~' \
- src/tests/session_encryption/crypt_session_read_uncrypt.phpt || die
- sed -i -e 's~%a/src~%a~' \
- src/tests/disable_function/disabled_functions_runtime.phpt || die
- php-ext-source-r3_src_prepare
-}
-
-src_install() {
- addtoinifile() {
- local inifile="${WORKDIR}/${1}"
- local inidir="${inifile%/*}"
-
- mkdir -p "${inidir}" || die "failed to create INI directory ${inidir}"
-
- local my_added="${2}=${3}"
- echo "${my_added}" >> "${inifile}" || die "failed to append to ${inifile}"
- einfo "Added '${my_added}' to /${1}"
-
- insinto "/${1%/*}"
- doins "${inifile}"
- }
- einstalldocs
- local slot x cfgdir
- php-ext-source-r3_src_install
- # Add the rules file which vary by install version
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- for x in ${PHP_EXT_SAPIS} ; do
- cfgdir="/etc/php/${x}-${slot}"
- if [[ -f "${ED}${cfgdir}/ext/${PHP_INI_NAME}.ini" ]]; then
- addtoinifile "${cfgdir#/}/ext/${PHP_INI_NAME}.ini" \
- "sp.configuration_file" "${cfgdir}/${PN}.rules"
- insinto "${cfgdir}"
- case ${PHP_CURRENTSLOT:0:1} in
- 8) newins "${S}/config/default_php8.rules" "${PN}.rules" ;;
- *) newins "${S}/config/default.rules" "${PN}.rules" ;;
- esac
- fi
- done
- done
-}
-
-pkg_postinst() {
- elog "This extension is configured with recommended rules enabled by default."
- elog "Feel free to customize as necessary. Please test outside of production first."
- elog "Failure to test may cause unexpected results to loosely coded sites."
-}