summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-09-23 10:41:24 -0400
committerBrian Evans <grknight@gentoo.org>2021-09-23 10:41:24 -0400
commit41c7e35cc617c5b79089ab4af123f2b5bac1f1b2 (patch)
treefdcb9dca31a4eb017a3e2cca00f9fdcc52dd163c /dev-php
parentwww-client/seamonkey: Disable ELF hack (diff)
downloadgentoo-41c7e35cc617c5b79089ab4af123f2b5bac1f1b2.tar.gz
gentoo-41c7e35cc617c5b79089ab4af123f2b5bac1f1b2.tar.bz2
gentoo-41c7e35cc617c5b79089ab4af123f2b5bac1f1b2.zip
dev-php/pecl-ssh2: Drop old
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-ssh2/Manifest3
-rw-r--r--dev-php/pecl-ssh2/files/pecl-ssh2-1.1.2-fix-php_url-fields-usage-for-php7-3.patch302
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-1.1.2.ebuild36
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-1.2.ebuild33
4 files changed, 0 insertions, 374 deletions
diff --git a/dev-php/pecl-ssh2/Manifest b/dev-php/pecl-ssh2/Manifest
index 4a420e281de7..0d800ebf183e 100644
--- a/dev-php/pecl-ssh2/Manifest
+++ b/dev-php/pecl-ssh2/Manifest
@@ -1,4 +1 @@
-DIST pecl-ssh2-1.1.2-fix-php7-port.patch 27860 BLAKE2B 23054187608bdcf79f53ce638e37c646f44297aa7d1e8f7a7c85fd922977ab835b915d541fbae327a30d2e863b503ed4822a82c1b242346290ceb94d49c97020 SHA512 1c2ecc990323a77fb2b69be0d6649f96dd7ad2d06c62f4fcb79a9ef4f89e066d463301668a044d37d717c99837c5d7d3f621f61119543445bd05c3229d9270e9
-DIST pecl-ssh2-1.2.tar.gz 32447 BLAKE2B 3a9d0f205097a381d07fb9dd5ab4dcb8e361f555dbc633abb8fa895c83024b70e85cd87602da1ceeb1018a7b07c474720b02810ef0689e9294fc33b129b6c738 SHA512 7b7d311cd5f88835e124d70a0295468f75d0fa6936a58808c936d1a185bb630b9e02c21f49b4bd777194a7b104aa3ff85c4fbf480f43d5906787e532ba2d3e04
-DIST ssh2-1.1.2.tgz 32057 BLAKE2B 88ffb3fb608687a086bbe345677982e944210791acc100312ba56ac7c35188a52cde5529d78caf473d19710e9965fba853ea9ff046715413a0b488ae2d8b690c SHA512 36793191448745b8a9b3cc628fe9fb431480792c7a2ff0bf2eccd58cda1cf944933be1d301c455d4a6f3dabf7e04ffef248bc402a8ff99bfafcba0deddb25c36
DIST ssh2-1.3.1.tgz 33838 BLAKE2B 05976ad143563fd9d51be3f8e23b5b22099e351d6f252b612aa1dcb56648dc337b623d2cddf7b9079f3e07c879ca69215a1987cd6f4326f97ba134e13c6d28e7 SHA512 c74d4f699853148b53cdca0eaf8837bfdbdd21d185761606acadf2442e84dbefdb00cde207e0ce4794ae1e4f8692a38ed903b6d11fdc57bca7b54a4250da9a76
diff --git a/dev-php/pecl-ssh2/files/pecl-ssh2-1.1.2-fix-php_url-fields-usage-for-php7-3.patch b/dev-php/pecl-ssh2/files/pecl-ssh2-1.1.2-fix-php_url-fields-usage-for-php7-3.patch
deleted file mode 100644
index 1f1352564220..000000000000
--- a/dev-php/pecl-ssh2/files/pecl-ssh2-1.1.2-fix-php_url-fields-usage-for-php7-3.patch
+++ /dev/null
@@ -1,302 +0,0 @@
-From a8835aab2c15e794fce13bd927295719e384ad2d Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Thu, 28 Jun 2018 07:10:35 +0200
-Subject: [PATCH] fix php_url fields usage for PHP 7.3
-
----
- php_ssh2.h | 8 ++++++++
- ssh2_fopen_wrappers.c | 55 ++++++++++++++++++++++++++++++++-------------------
- ssh2_sftp.c | 20 +++++++++----------
- 3 files changed, 53 insertions(+), 30 deletions(-)
-
-diff --git a/php_ssh2.h b/php_ssh2.h
-index 734b795..d010ff9 100644
---- a/php_ssh2.h
-+++ b/php_ssh2.h
-@@ -166,6 +166,14 @@ extern php_stream_wrapper php_ssh2_sftp_wrapper;
- extern int le_ssh2_session;
- extern int le_ssh2_sftp;
-
-+#if PHP_VERSION_ID < 70300
-+#define SSH2_URL_STR(a) (a)
-+#define SSH2_URL_LEN(a) strlen(a)
-+#else
-+#define SSH2_URL_STR(a) ZSTR_VAL(a)
-+#define SSH2_URL_LEN(a) ZSTR_LEN(a)
-+#endif
-+
- #endif /* PHP_SSH2_H */
-
- /*
-diff --git a/ssh2_fopen_wrappers.c b/ssh2_fopen_wrappers.c
-index 2f96ca4..f2f3475 100644
---- a/ssh2_fopen_wrappers.c
-+++ b/ssh2_fopen_wrappers.c
-@@ -215,7 +215,7 @@ php_url *php_ssh2_fopen_wraper_parse_path(const char *path, char *type, php_stre
- php_url *resource;
- zval *methods = NULL, *callbacks = NULL, zsession, *tmpzval;
- zend_long resource_id;
-- char *h, *s, *username = NULL, *password = NULL, *pubkey_file = NULL, *privkey_file = NULL;
-+ char *h, *username = NULL, *password = NULL, *pubkey_file = NULL, *privkey_file = NULL;
- int username_len = 0, password_len = 0;
-
- h = strstr(path, "Resource id #");
-@@ -233,13 +233,13 @@ php_url *php_ssh2_fopen_wraper_parse_path(const char *path, char *type, php_stre
- return NULL;
- }
-
-- if (strncmp(resource->scheme, "ssh2.", sizeof("ssh2.") - 1)) {
-+ if (strncmp(SSH2_URL_STR(resource->scheme), "ssh2.", sizeof("ssh2.") - 1)) {
- /* Not an ssh wrapper */
- php_url_free(resource);
- return NULL;
- }
-
-- if (strcmp(resource->scheme + sizeof("ssh2.") - 1, type)) {
-+ if (strcmp(SSH2_URL_STR(resource->scheme) + sizeof("ssh2.") - 1, type)) {
- /* Wrong ssh2. wrapper type */
- php_url_free(resource);
- return NULL;
-@@ -253,13 +253,27 @@ php_url *php_ssh2_fopen_wraper_parse_path(const char *path, char *type, php_stre
- Find resource->path in the path string, then copy the entire string from the original path.
- This includes ?query#fragment in the path string
- */
-+// TODO copy seems uneeded
-+#if PHP_VERSION_ID < 70300
-+ {
-+ char * s;
-+
- s = resource->path;
- resource->path = estrdup(strstr(path, resource->path));
- efree(s);
-+ }
-+#else
-+ {
-+ zend_string *tmp;
-+
-+ tmp = resource->path;
-+ resource->path = zend_string_init(ZSTR_VAL(resource->path), ZSTR_LEN(resource->path), 0);
-+ zend_string_release(tmp);
-+ }
-+#endif
-
- /* Look for a resource ID to reuse a session */
-- s = resource->host;
-- if (is_numeric_string(s, strlen(s), &resource_id, NULL, 0) == IS_LONG) {
-+ if (is_numeric_string(SSH2_URL_STR(resource->host), SSH2_URL_LEN(resource->host), &resource_id, NULL, 0) == IS_LONG) {
- php_ssh2_sftp_data *sftp_data;
- zval *zresource;
-
-@@ -309,7 +323,7 @@ php_url *php_ssh2_fopen_wraper_parse_path(const char *path, char *type, php_stre
- }
-
- /* Fallback on finding it in the context */
-- if (resource->host[0] == 0 && context && psftp &&
-+ if (SSH2_URL_STR(resource->host)[0] == 0 && context && psftp &&
- (tmpzval = php_stream_context_get_option(context, "ssh2", "sftp")) != NULL &&
- Z_TYPE_P(tmpzval) == IS_RESOURCE) {
- php_ssh2_sftp_data *sftp_data;
-@@ -323,7 +337,7 @@ php_url *php_ssh2_fopen_wraper_parse_path(const char *path, char *type, php_stre
- return resource;
- }
- }
-- if (resource->host[0] == 0 && context &&
-+ if (SSH2_URL_STR(resource->host)[0] == 0 && context &&
- (tmpzval = php_stream_context_get_option(context, "ssh2", "session")) != NULL &&
- Z_TYPE_P(tmpzval) == IS_RESOURCE) {
- session = (LIBSSH2_SESSION *)zend_fetch_resource(Z_RES_P(tmpzval), PHP_SSH2_SESSION_RES_NAME, le_ssh2_session);
-@@ -399,19 +413,19 @@ php_url *php_ssh2_fopen_wraper_parse_path(const char *path, char *type, php_stre
- }
-
- if (resource->user) {
-- int len = strlen(resource->user);
-+ int len = SSH2_URL_LEN(resource->user);
-
- if (len) {
-- username = resource->user;
-+ username = SSH2_URL_STR(resource->user);
- username_len = len;
- }
- }
-
- if (resource->pass) {
-- int len = strlen(resource->pass);
-+ int len = SSH2_URL_LEN(resource->pass);
-
- if (len) {
-- password = resource->pass;
-+ password = SSH2_URL_STR(resource->pass);
- password_len = len;
- }
- }
-@@ -422,7 +436,7 @@ php_url *php_ssh2_fopen_wraper_parse_path(const char *path, char *type, php_stre
- return NULL;
- }
-
-- session = php_ssh2_session_connect(resource->host, resource->port, methods, callbacks);
-+ session = php_ssh2_session_connect(SSH2_URL_STR(resource->host), resource->port, methods, callbacks);
- if (!session) {
- /* Unable to connect! */
- php_url_free(resource);
-@@ -482,6 +496,7 @@ session_authed:
- *psftp = sftp;
- }
-
-+ //TODO may be undefined
- *presource_id = Z_LVAL(zsession);
- *psession = session;
-
-@@ -527,7 +542,7 @@ static php_stream *php_ssh2_shell_open(LIBSSH2_SESSION *session, int resource_id
- zval_copy_ctor(&copyval);
- convert_to_string(&copyval);
- if (libssh2_channel_setenv_ex(channel, key->val, key->len, Z_STRVAL(copyval), Z_STRLEN(copyval))) {
-- php_error_docref(NULL, E_WARNING, "Failed setting %s=%s on remote end", key, Z_STRVAL(copyval));
-+ php_error_docref(NULL, E_WARNING, "Failed setting %s=%s on remote end", ZSTR_VAL(key), Z_STRVAL(copyval));
- }
- zval_dtor(&copyval);
- }
-@@ -631,7 +646,7 @@ static php_stream *php_ssh2_fopen_wrapper_shell(php_stream_wrapper *wrapper, con
- zval_ptr_dtor(&copyval);
- }
-
-- s = resource->path ? resource->path : NULL;
-+ s = resource->path ? SSH2_URL_STR(resource->path) : NULL;
-
- if (s && s[0] == '/') {
- /* Terminal type encoded into URL overrides context terminal type */
-@@ -766,7 +781,7 @@ static php_stream *php_ssh2_exec_command(LIBSSH2_SESSION *session, int resource_
- zval_copy_ctor(&copyval);
- convert_to_string(&copyval);
- if (libssh2_channel_setenv_ex(channel, key->val, key->len, Z_STRVAL(copyval), Z_STRLEN(copyval))) {
-- php_error_docref(NULL, E_WARNING, "Failed setting %s=%s on remote end", key, Z_STRVAL(copyval));
-+ php_error_docref(NULL, E_WARNING, "Failed setting %s=%s on remote end", ZSTR_VAL(key), Z_STRVAL(copyval));
- }
- zval_dtor(&copyval);
- }
-@@ -878,7 +893,7 @@ static php_stream *php_ssh2_fopen_wrapper_exec(php_stream_wrapper *wrapper, cons
- zval_ptr_dtor(copyval);
- }
-
-- stream = php_ssh2_exec_command(session, resource_id, resource->path + 1, terminal, terminal_len, environment, width, height, type);
-+ stream = php_ssh2_exec_command(session, resource_id, SSH2_URL_STR(resource->path) + 1, terminal, terminal_len, environment, width, height, type);
- if (!stream) {
- // TODO Sean-Der
- //zend_list_delete(resource_id);
-@@ -1021,7 +1036,7 @@ static php_stream *php_ssh2_fopen_wrapper_scp(php_stream_wrapper *wrapper, const
- return NULL;
- }
-
-- stream = php_ssh2_scp_xfer(session, resource_id, resource->path);
-+ stream = php_ssh2_scp_xfer(session, resource_id, SSH2_URL_STR(resource->path));
- if (!stream) {
- //TODO Sean-Der
- //zend_list_delete(resource_id);
-@@ -1147,7 +1162,7 @@ PHP_FUNCTION(ssh2_scp_send)
- char *error_msg = NULL;
-
- last_error = libssh2_session_last_error(session, &error_msg, NULL, 0);
-- php_error_docref(NULL, E_WARNING, "Failure creating remote file: %s", error_msg);
-+ php_error_docref(NULL, E_WARNING, "Failure creating remote file: %s (%d)", error_msg, last_error);
- php_stream_close(local_file);
- RETURN_FALSE;
- }
-@@ -1262,10 +1277,10 @@ static php_stream *php_ssh2_fopen_wrapper_tunnel(php_stream_wrapper *wrapper, co
- return NULL;
- }
-
-- if (resource->path && resource->path[0] == '/') {
-+ if (resource->path && SSH2_URL_STR(resource->path)[0] == '/') {
- char *colon;
-
-- host = resource->path + 1;
-+ host = SSH2_URL_STR(resource->path) + 1;
- if (*host == '[') {
- /* IPv6 Encapsulated Format */
- host++;
-diff --git a/ssh2_sftp.c b/ssh2_sftp.c
-index 13f89f0..6332be8 100644
---- a/ssh2_sftp.c
-+++ b/ssh2_sftp.c
-@@ -238,7 +238,7 @@ static php_stream *php_ssh2_sftp_stream_opener(php_stream_wrapper *wrapper, cons
-
- flags = php_ssh2_parse_fopen_modes((char *)mode);
-
-- handle = libssh2_sftp_open(sftp, resource->path, flags, perms);
-+ handle = libssh2_sftp_open(sftp, SSH2_URL_STR(resource->path), flags, perms);
- if (!handle) {
- php_error_docref(NULL, E_WARNING, "Unable to open %s on remote host", filename);
- php_url_free(resource);
-@@ -341,7 +341,7 @@ static php_stream *php_ssh2_sftp_dirstream_opener(php_stream_wrapper *wrapper, c
- return NULL;
- }
-
-- handle = libssh2_sftp_opendir(sftp, resource->path);
-+ handle = libssh2_sftp_opendir(sftp, SSH2_URL_STR(resource->path));
- if (!handle) {
- php_error_docref(NULL, E_WARNING, "Unable to open %s on remote host", filename);
- php_url_free(resource);
-@@ -386,7 +386,7 @@ static int php_ssh2_sftp_urlstat(php_stream_wrapper *wrapper, const char *url, i
- return -1;
- }
-
-- if (libssh2_sftp_stat_ex(sftp, resource->path, strlen(resource->path),
-+ if (libssh2_sftp_stat_ex(sftp, SSH2_URL_STR(resource->path), SSH2_URL_LEN(resource->path),
- (flags & PHP_STREAM_URL_STAT_LINK) ? LIBSSH2_SFTP_LSTAT : LIBSSH2_SFTP_STAT, &attrs)) {
- php_url_free(resource);
- //zend_list_delete(sftp_rsrcid);
-@@ -420,7 +420,7 @@ static int php_ssh2_sftp_unlink(php_stream_wrapper *wrapper, const char *url, in
- return 0;
- }
-
-- result = libssh2_sftp_unlink(sftp, resource->path);
-+ result = libssh2_sftp_unlink(sftp, SSH2_URL_STR(resource->path));
- php_url_free(resource);
-
- //zend_list_delete(sftp_rsrcid);
-@@ -462,7 +462,7 @@ static int php_ssh2_sftp_rename(php_stream_wrapper *wrapper, const char *url_fro
- return 0;
- }
-
-- result = libssh2_sftp_rename(sftp, resource->path, resource_to->path);
-+ result = libssh2_sftp_rename(sftp, SSH2_URL_STR(resource->path), SSH2_URL_STR(resource_to->path));
- php_url_free(resource);
- php_url_free(resource_to);
-
-@@ -493,13 +493,13 @@ static int php_ssh2_sftp_mkdir(php_stream_wrapper *wrapper, const char *url, int
-
- if (options & PHP_STREAM_MKDIR_RECURSIVE) {
- /* Just attempt to make every directory, some will fail, but we only care about the last success/failure */
-- char *p = resource->path;
-+ char *p = SSH2_URL_STR(resource->path);
- while ((p = strchr(p + 1, '/'))) {
-- libssh2_sftp_mkdir_ex(sftp, resource->path, p - resource->path, mode);
-+ libssh2_sftp_mkdir_ex(sftp, SSH2_URL_STR(resource->path), p - SSH2_URL_STR(resource->path), mode);
- }
- }
-
-- result = libssh2_sftp_mkdir(sftp, resource->path, mode);
-+ result = libssh2_sftp_mkdir(sftp, SSH2_URL_STR(resource->path), mode);
- php_url_free(resource);
-
- //zend_list_delete(sftp_rsrcid);
-@@ -527,7 +527,7 @@ static int php_ssh2_sftp_rmdir(php_stream_wrapper *wrapper, const char *url, int
- return 0;
- }
-
-- result = libssh2_sftp_rmdir(sftp, resource->path);
-+ result = libssh2_sftp_rmdir(sftp, SSH2_URL_STR(resource->path));
- php_url_free(resource);
-
- //zend_list_delete(sftp_rsrcid);
-@@ -836,7 +836,7 @@ PHP_FUNCTION(ssh2_sftp_readlink)
- }
-
- if ((targ_len = libssh2_sftp_symlink_ex(data->sftp, link->val, link->len, targ, 8192, LIBSSH2_SFTP_READLINK)) < 0) {
-- php_error_docref(NULL, E_WARNING, "Unable to read link '%s'", link);
-+ php_error_docref(NULL, E_WARNING, "Unable to read link '%s'", ZSTR_VAL(link));
- RETURN_FALSE;
- }
-
---
-2.1.4
-
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-1.1.2.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-1.1.2.ebuild
deleted file mode 100644
index a27f6970b153..000000000000
--- a/dev-php/pecl-ssh2/pecl-ssh2-1.1.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PHP_EXT_NAME="ssh2"
-
-USE_PHP="php5-6 php7-1 php7-2 php7-3"
-
-inherit php-ext-pecl-r3
-
-USE_PHP="php7-1 php7-2 php7-3"
-
-DESCRIPTION="PHP bindings for the libssh2 library"
-LICENSE="PHP-3.01"
-SLOT="7"
-
-SRC_URI+=" https://dev.gentoo.org/~juippis/distfiles/tmp/pecl-ssh2-1.1.2-fix-php7-port.patch"
-KEYWORDS="amd64 x86"
-# Upstream notes say there are errors with gcrypt backend
-DEPEND=">=net-libs/libssh2-1.2[-gcrypt]"
-RDEPEND="${DEPEND}
- php_targets_php5-6? ( dev-php/pecl-ssh2:0[php_targets_php5-6] )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-fix-php_url-fields-usage-for-php7-3.patch
- "${DISTDIR}"/${P}-fix-php7-port.patch
-)
-
-src_prepare() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3; then
- php-ext-source-r3_src_prepare
- else
- default_src_prepare
- fi
-}
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-1.2.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-1.2.ebuild
deleted file mode 100644
index ffc132c93745..000000000000
--- a/dev-php/pecl-ssh2/pecl-ssh2-1.2.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PHP_EXT_NAME="ssh2"
-
-USE_PHP="php5-6 php7-1 php7-2 php7-3 php7-4"
-
-inherit php-ext-pecl-r3
-
-# https://pecl.php.net/get/ssh2-1.2.tgz isn't work for some weeks
-SRC_URI="https://dev.gentoo.org/~whissi/dist/${PN}/${P}.tar.gz"
-
-USE_PHP="php7-1 php7-2 php7-3 php7-4"
-
-DESCRIPTION="PHP bindings for the libssh2 library"
-LICENSE="PHP-3.01"
-SLOT="7"
-IUSE=""
-KEYWORDS="~amd64 ~x86"
-# Upstream notes say there are errors with gcrypt backend
-DEPEND=">=net-libs/libssh2-1.2[-gcrypt]"
-RDEPEND="${DEPEND}
- php_targets_php5-6? ( dev-php/pecl-ssh2:0[php_targets_php5-6] )"
-
-src_prepare() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- php-ext-source-r3_src_prepare
- else
- default_src_prepare
- fi
-}