summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-02-22 15:43:51 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-02-22 15:43:51 +0100
commit42087c479104d6215ba6308e86b2f2356d51acac (patch)
tree06166b287220bdc84fe12bd9d49d294cf1bc960a /dev-php
parentdev-php/PHPMailer: bump to v6.0.7 (diff)
downloadgentoo-42087c479104d6215ba6308e86b2f2356d51acac.tar.gz
gentoo-42087c479104d6215ba6308e86b2f2356d51acac.tar.bz2
gentoo-42087c479104d6215ba6308e86b2f2356d51acac.zip
dev-php/PHPMailer: bump to v5.2.27
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PHPMailer/Manifest1
-rw-r--r--dev-php/PHPMailer/PHPMailer-5.2.27.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-php/PHPMailer/Manifest b/dev-php/PHPMailer/Manifest
index 54d4081480a9..d75e2fabb64d 100644
--- a/dev-php/PHPMailer/Manifest
+++ b/dev-php/PHPMailer/Manifest
@@ -1,3 +1,4 @@
DIST PHPMailer-5.2.26.tar.gz 159174 BLAKE2B 989ee85f6ca374bd7f4accf3d18fbd173bbbd3176e6846c9a2aec68f3bfca4ead4e0197f6287e2bc8ed4a125bf7fcb53240a1f8ce6a1813eaffb66067c2c4e9e SHA512 4c3e324ecd1dd23eb40f14ee785fb9b353b742ff4fb26fe0586622038157e60d64560f5ba4a625f16fad6568954d685ebbe436d88bc427d5bd260c056815b656
+DIST PHPMailer-5.2.27.tar.gz 159227 BLAKE2B e5ff2dd62cb12396bee58f0dce2fec3148dcf425cd91d69b76659ded7c38d8d5dea4830649dbeaa4732e098deecfe7ee77e338497b080997a44fbcf28d0833c7 SHA512 5a466133feec323d3739b9a1bde36731f5e65ecf61aa3f2fa6cc4ed0bd6f9280f8e2a17b6b7ac481846509ba3e8b0b97062f0dbbd644ccec3884b7a03f489a1b
DIST PHPMailer-6.0.5.tar.gz 88092 BLAKE2B 0b2113b54d547d788c54cbcf18fe134a6b08f6b9eabcbad308a7d0bba8e95426fd8be77419419cbe0379be080350a1caf1690cbe3f096c178cc3a8c9506d9529 SHA512 5b18700ef26fe5de20a7ca291ece44b897182c603ed8187e0f711099325b35b20f8dbab2c456eaac1338731356661237d9b249c2f40051807b0d58ead612013c
DIST PHPMailer-6.0.7.tar.gz 91706 BLAKE2B 1d3d22dea463040840c1259cfbdbcf2da59cd31e915ea8a73bb9981844e9ae6e32ca1e9a40a576fedcd8c0a049f92f9b5422040e12dcc66b2c555dbd36126c67 SHA512 0d00ff177fc82c3cc54ed04cfd333739c9346f89dba1ccb8bdcccc01abd3de4c55c96dbd51cc0f4cc76d6690acd22c6bb4f632dcfb785ec1d0a32a8751ddf6e9
diff --git a/dev-php/PHPMailer/PHPMailer-5.2.27.ebuild b/dev-php/PHPMailer/PHPMailer-5.2.27.ebuild
new file mode 100644
index 000000000000..00117b7fc6e4
--- /dev/null
+++ b/dev-php/PHPMailer/PHPMailer-5.2.27.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Full-featured email creation and transfer class for PHP"
+HOMEPAGE="https://github.com/PHPMailer/PHPMailer"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples idn ssl"
+
+# The ctype and filter extensions get used unconditionally, with no
+# fallback and no "extension missing" exception. All of the other
+# extensions are technically optional, depending on how you use
+# PHPMailer and whether or not you're willing to settle for fallback
+# implementations.
+#
+# The insane dependency string is to prevent the ctype and filter
+# extensions from being provided by one version (i.e. slot) of PHP,
+# while intl and unicode are provided by another.
+RDEPEND="
+ ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,ssl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter,ssl] )
+ )
+ !ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter] )
+ )"
+DEPEND="${RDEPEND}
+ doc? ( dev-php/phpDocumentor )"
+
+src_compile(){
+ if use doc; then
+ phpdoc --filename="class.*.php" \
+ --target="./html" \
+ --cache-folder="${T}" \
+ --title="${PN}" \
+ --sourcecode \
+ --force \
+ --progressbar \
+ || die "failed to generate API documentation"
+ fi
+}
+
+src_install(){
+ # To help out the Composer kids, most of the documentation and
+ # tests are missing from the release tarballs.
+ insinto "/usr/share/php/${PN}"
+ doins -r *.php language extras
+
+ use examples && dodoc -r examples
+ use doc && dodoc -r html/*
+}
+
+pkg_postinst(){
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "To use it in a script, require('${PN}/${PN}Autoload.php'),"
+ elog "and then use the ${PN} class normally. Most of the examples in"
+ elog "the documentation should work without further modification."
+}