summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-28 23:19:55 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-28 23:47:51 +0100
commit4709539586c6ee236fc7dac0c541a9d2b689044b (patch)
tree97b439c2b49068ce3b03ccb5904863b58a809fde /dev-php
parentdev-php/pecl-gnupg: add PHP 7.4 support (diff)
downloadgentoo-4709539586c6ee236fc7dac0c541a9d2b689044b.tar.gz
gentoo-4709539586c6ee236fc7dac0c541a9d2b689044b.tar.bz2
gentoo-4709539586c6ee236fc7dac0c541a9d2b689044b.zip
dev-php/pecl-propro: add PHP 7.4 support
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-propro/pecl-propro-2.1.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-php/pecl-propro/pecl-propro-2.1.0.ebuild b/dev-php/pecl-propro/pecl-propro-2.1.0.ebuild
index ba645a7a2b18..42fb351d1518 100644
--- a/dev-php/pecl-propro/pecl-propro-2.1.0.ebuild
+++ b/dev-php/pecl-propro/pecl-propro-2.1.0.ebuild
@@ -9,12 +9,12 @@ PHP_EXT_ZENDEXT="no"
PHP_EXT_ECONF_ARGS=""
PHP_INI_NAME="30-${PHP_EXT_NAME}"
-USE_PHP="php5-6 php7-1 php7-2 php7-3"
+USE_PHP="php5-6 php7-1 php7-2 php7-3 php7-4"
inherit php-ext-pecl-r3
# Only really build for 7.x
-USE_PHP="php7-1 php7-2 php7-3"
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
KEYWORDS="~amd64 ~x86"
@@ -26,7 +26,7 @@ IUSE=""
RDEPEND="php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6] )"
src_prepare() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
php-ext-source-r3_src_prepare
else
default_src_prepare
@@ -34,7 +34,7 @@ src_prepare() {
}
src_install() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
php-ext-pecl-r3_src_install
fi
}