summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-01-06 09:21:23 -0500
committerBrian Evans <grknight@gentoo.org>2017-01-06 09:21:23 -0500
commit4b7abacb9f6acf9e4ac48ff3991290a9ef54abfe (patch)
treeef3e76e67aa8d51620eff1e186b0f0c61a5ed73c /dev-php
parentnet-irc/irssi-0.8.21-r0: stable on alpha (diff)
downloadgentoo-4b7abacb9f6acf9e4ac48ff3991290a9ef54abfe.tar.gz
gentoo-4b7abacb9f6acf9e4ac48ff3991290a9ef54abfe.tar.bz2
gentoo-4b7abacb9f6acf9e4ac48ff3991290a9ef54abfe.zip
dev-php/pecl-http: Fix build failure with curl_ssl_gnutls USE
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-http/files/pecl-http-gnutls.patch24
-rw-r--r--dev-php/pecl-http/pecl-http-3.1.0.ebuild4
2 files changed, 27 insertions, 1 deletions
diff --git a/dev-php/pecl-http/files/pecl-http-gnutls.patch b/dev-php/pecl-http/files/pecl-http-gnutls.patch
new file mode 100644
index 000000000000..4b58805946dc
--- /dev/null
+++ b/dev-php/pecl-http/files/pecl-http-gnutls.patch
@@ -0,0 +1,24 @@
+diff -aurN a/autoconf/pecl/libcurl.m4 b/autoconf/pecl/libcurl.m4
+--- a/autoconf/pecl/libcurl.m4 2016-12-12 04:04:21.000000000 -0500
++++ b/autoconf/pecl/libcurl.m4 2017-01-06 09:07:17.575660038 -0500
+@@ -87,7 +87,7 @@
+ AC_REQUIRE([PECL_HAVE_LIBCURL_CA])dnl
+ PECL_HAVE_LIBCURL_FEATURE([SSL], [
+ PECL_HAVE_LIBCURL_SSLLIB([OpenSSL], [openssl/ssl.h openssl/crypto.h], [ssl crypto])
+- PECL_HAVE_LIBCURL_SSLLIB([GnuTLS], [gnutls.h gcrypt.h], [gnutls gcrypt])
++ PECL_HAVE_LIBCURL_SSLLIB([GnuTLS], [gnutls/gnutls.h gcrypt.h], [gnutls gcrypt])
+ PECL_HAVE_LIBCURL_SSLLIB([NSS])
+ PECL_HAVE_LIBCURL_SSLLIB([SecureTransport])
+ PECL_HAVE_LIBCURL_SSLLIB([GSKit])
+diff -aurN a/src/php_http_client_curl.c b/src/php_http_client_curl.c
+--- a/src/php_http_client_curl.c 2016-12-12 04:04:21.000000000 -0500
++++ b/src/php_http_client_curl.c 2017-01-06 09:09:01.631772852 -0500
+@@ -21,7 +21,7 @@
+ # include <openssl/ssl.h>
+ #endif
+ #if PHP_HTTP_HAVE_LIBCURL_GNUTLS
+-# include <gnutls.h>
++# include <gnutls/gnutls.h>
+ #endif
+
+ typedef struct php_http_client_curl_handler {
diff --git a/dev-php/pecl-http/pecl-http-3.1.0.ebuild b/dev-php/pecl-http/pecl-http-3.1.0.ebuild
index d74da5940a22..3c43ba02595b 100644
--- a/dev-php/pecl-http/pecl-http-3.1.0.ebuild
+++ b/dev-php/pecl-http/pecl-http-3.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -36,6 +36,8 @@ RDEPEND="${DEPEND}
PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps )
+PATCHES=( "${FILESDIR}/pecl-http-gnutls.patch" )
+
src_prepare() {
if use php_targets_php7-0 || use php_targets_php7-1 ; then
php-ext-source-r3_src_prepare