summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-12-20 12:46:53 -0500
committerBrian Evans <grknight@gentoo.org>2019-12-20 13:34:21 -0500
commit8d8ad63790ed8a8389903ee6f5c06c69e7b80900 (patch)
tree4c3ef5899332554dad37a041b761b01449c43661 /dev-php
parentdev-php/sebastian-resource-operations: Version bump for 2.0.1 (diff)
downloadgentoo-8d8ad63790ed8a8389903ee6f5c06c69e7b80900.tar.gz
gentoo-8d8ad63790ed8a8389903ee6f5c06c69e7b80900.tar.bz2
gentoo-8d8ad63790ed8a8389903ee6f5c06c69e7b80900.zip
dev-php/phpunit: Version bump for 8.5.0
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/phpunit/Manifest1
-rw-r--r--dev-php/phpunit/files/autoload-8.5.0.php254
-rw-r--r--dev-php/phpunit/phpunit-8.5.0.ebuild66
3 files changed, 321 insertions, 0 deletions
diff --git a/dev-php/phpunit/Manifest b/dev-php/phpunit/Manifest
index 6f03af2279b4..f3e1b2cc4b50 100644
--- a/dev-php/phpunit/Manifest
+++ b/dev-php/phpunit/Manifest
@@ -1 +1,2 @@
DIST phpunit-5.7.15.tar.gz 205474 BLAKE2B 0220edd59fc3f191b7621f275d3e4ee8f8bf514f74533d99bfb925e11cc54a235fb292ffd1bb54f6bec1e038c06e35a0dc43c1227618590f99e7e85638a7de28 SHA512 6a836e1ad1656fd1d1c5a58ced3c1826b4decc01798b6a804b487c9b4e094ec32f6eb8a84058e268eade62a2fe19d7bd1e760b8b9433299d9fe9c09afdf2bdd3
+DIST phpunit-8.5.0.tar.gz 311500 BLAKE2B 1b21b898f8a933a228bb6f0197e1a884fe1ab67e7774194d32d23393b2ee649a307e0d00cc6a3b89bad19ab5abc22de8fbc99ff41dc69a006117eabe626cd86a SHA512 3f2c615fbe05c2c04db71b237716ffa3a9ac2c0a5e490fea5db9780efe7f825d47ebb04e81dcdbd4c55f2c3667caf2de79cdbeece6c10ec999c9786fee245721
diff --git a/dev-php/phpunit/files/autoload-8.5.0.php b/dev-php/phpunit/files/autoload-8.5.0.php
new file mode 100644
index 000000000000..2177c3daa4c4
--- /dev/null
+++ b/dev-php/phpunit/files/autoload-8.5.0.php
@@ -0,0 +1,254 @@
+/* Autoloader for dev-php/phpunit and its dependencies */
+
+$include_dir = '/usr/share/php';
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once "${include_dir}/Fedora/Autoloader/autoload.php";
+}
+
+\Fedora\Autoloader\Autoload::addClassMap(
+[
+'phpunit\\exception' => '/Exception.php',
+'phpunit\\framework\\assert' => '/Framework/Assert.php',
+'phpunit\\framework\\assertionfailederror' => '/Framework/Exception/AssertionFailedError.php',
+'phpunit\\framework\\codecoverageexception' => '/Framework/Exception/CodeCoverageException.php',
+'phpunit\\framework\\constraint\\arrayhaskey' => '/Framework/Constraint/ArrayHasKey.php',
+'phpunit\\framework\\constraint\\arraysubset' => '/Framework/Constraint/ArraySubset.php',
+'phpunit\\framework\\constraint\\attribute' => '/Framework/Constraint/Attribute.php',
+'phpunit\\framework\\constraint\\callback' => '/Framework/Constraint/Callback.php',
+'phpunit\\framework\\constraint\\classhasattribute' => '/Framework/Constraint/ClassHasAttribute.php',
+'phpunit\\framework\\constraint\\classhasstaticattribute' => '/Framework/Constraint/ClassHasStaticAttribute.php',
+'phpunit\\framework\\constraint\\composite' => '/Framework/Constraint/Composite.php',
+'phpunit\\framework\\constraint\\constraint' => '/Framework/Constraint/Constraint.php',
+'phpunit\\framework\\constraint\\count' => '/Framework/Constraint/Count.php',
+'phpunit\\framework\\constraint\\directoryexists' => '/Framework/Constraint/DirectoryExists.php',
+'phpunit\\framework\\constraint\\exception' => '/Framework/Constraint/Exception.php',
+'phpunit\\framework\\constraint\\exceptioncode' => '/Framework/Constraint/ExceptionCode.php',
+'phpunit\\framework\\constraint\\exceptionmessage' => '/Framework/Constraint/ExceptionMessage.php',
+'phpunit\\framework\\constraint\\exceptionmessageregularexpression' => '/Framework/Constraint/ExceptionMessageRegularExpression.php',
+'phpunit\\framework\\constraint\\fileexists' => '/Framework/Constraint/FileExists.php',
+'phpunit\\framework\\constraint\\greaterthan' => '/Framework/Constraint/GreaterThan.php',
+'phpunit\\framework\\constraint\\isanything' => '/Framework/Constraint/IsAnything.php',
+'phpunit\\framework\\constraint\\isempty' => '/Framework/Constraint/IsEmpty.php',
+'phpunit\\framework\\constraint\\isequal' => '/Framework/Constraint/IsEqual.php',
+'phpunit\\framework\\constraint\\isfalse' => '/Framework/Constraint/IsFalse.php',
+'phpunit\\framework\\constraint\\isfinite' => '/Framework/Constraint/IsFinite.php',
+'phpunit\\framework\\constraint\\isidentical' => '/Framework/Constraint/IsIdentical.php',
+'phpunit\\framework\\constraint\\isinfinite' => '/Framework/Constraint/IsInfinite.php',
+'phpunit\\framework\\constraint\\isinstanceof' => '/Framework/Constraint/IsInstanceOf.php',
+'phpunit\\framework\\constraint\\isjson' => '/Framework/Constraint/IsJson.php',
+'phpunit\\framework\\constraint\\isnan' => '/Framework/Constraint/IsNan.php',
+'phpunit\\framework\\constraint\\isnull' => '/Framework/Constraint/IsNull.php',
+'phpunit\\framework\\constraint\\isreadable' => '/Framework/Constraint/IsReadable.php',
+'phpunit\\framework\\constraint\\istrue' => '/Framework/Constraint/IsTrue.php',
+'phpunit\\framework\\constraint\\istype' => '/Framework/Constraint/IsType.php',
+'phpunit\\framework\\constraint\\iswritable' => '/Framework/Constraint/IsWritable.php',
+'phpunit\\framework\\constraint\\jsonmatches' => '/Framework/Constraint/JsonMatches.php',
+'phpunit\\framework\\constraint\\jsonmatcheserrormessageprovider' => '/Framework/Constraint/JsonMatchesErrorMessageProvider.php',
+'phpunit\\framework\\constraint\\lessthan' => '/Framework/Constraint/LessThan.php',
+'phpunit\\framework\\constraint\\logicaland' => '/Framework/Constraint/LogicalAnd.php',
+'phpunit\\framework\\constraint\\logicalnot' => '/Framework/Constraint/LogicalNot.php',
+'phpunit\\framework\\constraint\\logicalor' => '/Framework/Constraint/LogicalOr.php',
+'phpunit\\framework\\constraint\\logicalxor' => '/Framework/Constraint/LogicalXor.php',
+'phpunit\\framework\\constraint\\objecthasattribute' => '/Framework/Constraint/ObjectHasAttribute.php',
+'phpunit\\framework\\constraint\\regularexpression' => '/Framework/Constraint/RegularExpression.php',
+'phpunit\\framework\\constraint\\samesize' => '/Framework/Constraint/SameSize.php',
+'phpunit\\framework\\constraint\\stringcontains' => '/Framework/Constraint/StringContains.php',
+'phpunit\\framework\\constraint\\stringendswith' => '/Framework/Constraint/StringEndsWith.php',
+'phpunit\\framework\\constraint\\stringmatchesformatdescription' => '/Framework/Constraint/StringMatchesFormatDescription.php',
+'phpunit\\framework\\constraint\\stringstartswith' => '/Framework/Constraint/StringStartsWith.php',
+'phpunit\\framework\\constraint\\traversablecontains' => '/Framework/Constraint/TraversableContains.php',
+'phpunit\\framework\\constraint\\traversablecontainsequal' => '/Framework/Constraint/TraversableContainsEqual.php',
+'phpunit\\framework\\constraint\\traversablecontainsidentical' => '/Framework/Constraint/TraversableContainsIdentical.php',
+'phpunit\\framework\\constraint\\traversablecontainsonly' => '/Framework/Constraint/TraversableContainsOnly.php',
+'phpunit\\framework\\coveredcodenotexecutedexception' => '/Framework/Exception/CoveredCodeNotExecutedException.php',
+'phpunit\\framework\\dataprovidertestsuite' => '/Framework/DataProviderTestSuite.php',
+'phpunit\\framework\\error\\deprecated' => '/Framework/Error/Deprecated.php',
+'phpunit\\framework\\error\\error' => '/Framework/Error/Error.php',
+'phpunit\\framework\\error\\notice' => '/Framework/Error/Notice.php',
+'phpunit\\framework\\error\\warning' => '/Framework/Error/Warning.php',
+'phpunit\\framework\\exception' => '/Framework/Exception/Exception.php',
+'phpunit\\framework\\exceptionwrapper' => '/Framework/ExceptionWrapper.php',
+'phpunit\\framework\\expectationfailedexception' => '/Framework/Exception/ExpectationFailedException.php',
+'phpunit\\framework\\incompletetest' => '/Framework/IncompleteTest.php',
+'phpunit\\framework\\incompletetestcase' => '/Framework/IncompleteTestCase.php',
+'phpunit\\framework\\incompletetesterror' => '/Framework/Exception/IncompleteTestError.php',
+'phpunit\\framework\\invalidargumentexception' => '/Framework/Exception/InvalidArgumentException.php',
+'phpunit\\framework\\invalidcoverstargetexception' => '/Framework/Exception/InvalidCoversTargetException.php',
+'phpunit\\framework\\invaliddataproviderexception' => '/Framework/Exception/InvalidDataProviderException.php',
+'phpunit\\framework\\invalidparametergroupexception' => '/Framework/InvalidParameterGroupException.php',
+'phpunit\\framework\\missingcoversannotationexception' => '/Framework/Exception/MissingCoversAnnotationException.php',
+'phpunit\\framework\\mockobject\\api' => '/Framework/MockObject/Api/Api.php',
+'phpunit\\framework\\mockobject\\badmethodcallexception' => '/Framework/MockObject/Exception/BadMethodCallException.php',
+'phpunit\\framework\\mockobject\\builder\\identity' => '/Framework/MockObject/Builder/Identity.php',
+'phpunit\\framework\\mockobject\\builder\\invocationmocker' => '/Framework/MockObject/Builder/InvocationMocker.php',
+'phpunit\\framework\\mockobject\\builder\\invocationstubber' => '/Framework/MockObject/Builder/InvocationStubber.php',
+'phpunit\\framework\\mockobject\\builder\\match' => '/Framework/MockObject/Builder/Match.php',
+'phpunit\\framework\\mockobject\\builder\\methodnamematch' => '/Framework/MockObject/Builder/MethodNameMatch.php',
+'phpunit\\framework\\mockobject\\builder\\parametersmatch' => '/Framework/MockObject/Builder/ParametersMatch.php',
+'phpunit\\framework\\mockobject\\builder\\stub' => '/Framework/MockObject/Builder/Stub.php',
+'phpunit\\framework\\mockobject\\configurablemethod' => '/Framework/MockObject/ConfigurableMethod.php',
+'phpunit\\framework\\mockobject\\configurablemethodsalreadyinitializedexception' => '/Framework/MockObject/Exception/ConfigurableMethodsAlreadyInitializedException.php',
+'phpunit\\framework\\mockobject\\exception' => '/Framework/MockObject/Exception/Exception.php',
+'phpunit\\framework\\mockobject\\generator' => '/Framework/MockObject/Generator.php',
+'phpunit\\framework\\mockobject\\incompatiblereturnvalueexception' => '/Framework/MockObject/Exception/IncompatibleReturnValueException.php',
+'phpunit\\framework\\mockobject\\invocation' => '/Framework/MockObject/Invocation.php',
+'phpunit\\framework\\mockobject\\invocationhandler' => '/Framework/MockObject/InvocationHandler.php',
+'phpunit\\framework\\mockobject\\matcher' => '/Framework/MockObject/Matcher.php',
+'phpunit\\framework\\mockobject\\method' => '/Framework/MockObject/Api/Method.php',
+'phpunit\\framework\\mockobject\\methodnameconstraint' => '/Framework/MockObject/MethodNameConstraint.php',
+'phpunit\\framework\\mockobject\\mockbuilder' => '/Framework/MockObject/MockBuilder.php',
+'phpunit\\framework\\mockobject\\mockclass' => '/Framework/MockObject/MockClass.php',
+'phpunit\\framework\\mockobject\\mockmethod' => '/Framework/MockObject/MockMethod.php',
+'phpunit\\framework\\mockobject\\mockmethodset' => '/Framework/MockObject/MockMethodSet.php',
+'phpunit\\framework\\mockobject\\mockobject' => '/Framework/MockObject/MockObject.php',
+'phpunit\\framework\\mockobject\\mocktrait' => '/Framework/MockObject/MockTrait.php',
+'phpunit\\framework\\mockobject\\mocktype' => '/Framework/MockObject/MockType.php',
+'phpunit\\framework\\mockobject\\mockedclonemethod' => '/Framework/MockObject/Api/MockedCloneMethod.php',
+'phpunit\\framework\\mockobject\\rule\\anyinvokedcount' => '/Framework/MockObject/Rule/AnyInvokedCount.php',
+'phpunit\\framework\\mockobject\\rule\\anyparameters' => '/Framework/MockObject/Rule/AnyParameters.php',
+'phpunit\\framework\\mockobject\\rule\\consecutiveparameters' => '/Framework/MockObject/Rule/ConsecutiveParameters.php',
+'phpunit\\framework\\mockobject\\rule\\invocationorder' => '/Framework/MockObject/Rule/InvocationOrder.php',
+'phpunit\\framework\\mockobject\\rule\\invokedatindex' => '/Framework/MockObject/Rule/InvokedAtIndex.php',
+'phpunit\\framework\\mockobject\\rule\\invokedatleastcount' => '/Framework/MockObject/Rule/InvokedAtLeastCount.php',
+'phpunit\\framework\\mockobject\\rule\\invokedatleastonce' => '/Framework/MockObject/Rule/InvokedAtLeastOnce.php',
+'phpunit\\framework\\mockobject\\rule\\invokedatmostcount' => '/Framework/MockObject/Rule/InvokedAtMostCount.php',
+'phpunit\\framework\\mockobject\\rule\\invokedcount' => '/Framework/MockObject/Rule/InvokedCount.php',
+'phpunit\\framework\\mockobject\\rule\\methodname' => '/Framework/MockObject/Rule/MethodName.php',
+'phpunit\\framework\\mockobject\\rule\\parameters' => '/Framework/MockObject/Rule/Parameters.php',
+'phpunit\\framework\\mockobject\\rule\\parametersrule' => '/Framework/MockObject/Rule/ParametersRule.php',
+'phpunit\\framework\\mockobject\\runtimedxception' => '/Framework/MockObject/Exception/RuntimeException.php',
+'phpunit\\framework\\mockobject\\stub' => '/Framework/MockObject/Stub.php',
+'phpunit\\framework\\mockobject\\stub\\consecutivecalls' => '/Framework/MockObject/Stub/ConsecutiveCalls.php',
+'phpunit\\framework\\mockobject\\stub\\exception' => '/Framework/MockObject/Stub/Exception.php',
+'phpunit\\framework\\mockobject\\stub\\returnargument' => '/Framework/MockObject/Stub/ReturnArgument.php',
+'phpunit\\framework\\mockobject\\stub\\returncallback' => '/Framework/MockObject/Stub/ReturnCallback.php',
+'phpunit\\framework\\mockobject\\stub\\returnreference' => '/Framework/MockObject/Stub/ReturnReference.php',
+'phpunit\\framework\\mockobject\\stub\\returnself' => '/Framework/MockObject/Stub/ReturnSelf.php',
+'phpunit\\framework\\mockobject\\stub\\returnstub' => '/Framework/MockObject/Stub/ReturnStub.php',
+'phpunit\\framework\\mockobject\\stub\\returnvaluemap' => '/Framework/MockObject/Stub/ReturnValueMap.php',
+'phpunit\\framework\\mockobject\\stub\\stub' => '/Framework/MockObject/Stub/Stub.php',
+'phpunit\\framework\\mockobject\\unmockedclonemethod' => '/Framework/MockObject/Api/UnmockedCloneMethod.php',
+'phpunit\\framework\\mockobject\\verifiable' => '/Framework/MockObject/Verifiable.php',
+'phpunit\\framework\\nochildtestsuiteexception' => '/Framework/Exception/NoChildTestSuiteException.php',
+'phpunit\\framework\\outputerror' => '/Framework/Exception/OutputError.php',
+'phpunit\\framework\\phptassertionfailederror' => '/Framework/Exception/PHPTAssertionFailedError.php',
+'phpunit\\framework\\riskytesterror' => '/Framework/Exception/RiskyTestError.php',
+'phpunit\\framework\\selfdescribing' => '/Framework/SelfDescribing.php',
+'phpunit\\framework\\skippedtest' => '/Framework/SkippedTest.php',
+'phpunit\\framework\\skippedtestcase' => '/Framework/SkippedTestCase.php',
+'phpunit\\framework\\skippedtesterror' => '/Framework/Exception/SkippedTestError.php',
+'phpunit\\framework\\skippedtestsuiteerror' => '/Framework/Exception/SkippedTestSuiteError.php',
+'phpunit\\framework\\syntheticerror' => '/Framework/Exception/SyntheticError.php',
+'phpunit\\framework\\syntheticskippederror' => '/Framework/Exception/SyntheticSkippedError.php',
+'phpunit\\framework\\test' => '/Framework/Test.php',
+'phpunit\\framework\\testbuilder' => '/Framework/TestBuilder.php',
+'phpunit\\framework\\testcase' => '/Framework/TestCase.php',
+'phpunit\\framework\\testfailure' => '/Framework/TestFailure.php',
+'phpunit\\framework\\testlistener' => '/Framework/TestListener.php',
+'phpunit\\framework\\testlistenerdefaultimplementation' => '/Framework/TestListenerDefaultImplementation.php',
+'phpunit\\framework\\testresult' => '/Framework/TestResult.php',
+'phpunit\\framework\\testsuite' => '/Framework/TestSuite.php',
+'phpunit\\framework\\testsuiteiterator' => '/Framework/TestSuiteIterator.php',
+'phpunit\\framework\\unintentionallycoveredcodeerror' => '/Framework/Exception/UnintentionallyCoveredCodeError.php',
+'phpunit\\framework\\warning' => '/Framework/Exception/Warning.php',
+'phpunit\\framework\\warningTestCase' => '/Framework/WarningTestCase.php',
+'phpunit\\runner\\afterincompletetesthook' => '/Runner/Hook/AfterIncompleteTestHook.php',
+'phpunit\\runner\\afterlasttesthook' => '/Runner/Hook/AfterLastTestHook.php',
+'phpunit\\runner\\afterriskytesthook' => '/Runner/Hook/AfterRiskyTestHook.php',
+'phpunit\\runner\\afterskippedtesthook' => '/Runner/Hook/AfterSkippedTestHook.php',
+'phpunit\\runner\\aftersuccessfultesthook' => '/Runner/Hook/AfterSuccessfulTestHook.php',
+'phpunit\\runner\\aftertesterrorhook' => '/Runner/Hook/AfterTestErrorHook.php',
+'phpunit\\runner\\aftertestfailurehook' => '/Runner/Hook/AfterTestFailureHook.php',
+'phpunit\\runner\\aftertesthook' => '/Runner/Hook/AfterTestHook.php',
+'phpunit\\runner\\aftertestwarninghook' => '/Runner/Hook/AfterTestWarningHook.php',
+'phpunit\\runner\\basetestrunner' => '/Runner/BaseTestRunner.php',
+'phpunit\\runner\\beforefirsttesthHook' => '/Runner/Hook/BeforeFirstTestHook.php',
+'phpunit\\runner\\beforetesthook' => '/Runner/Hook/BeforeTestHook.php',
+'phpunit\\runner\\defaulttestresultcache' => '/Runner/DefaultTestResultCache.php',
+'phpunit\\runner\\exception' => '/Runner/Exception.php',
+'phpunit\\runner\\filter\\excludegroupfilteriterator' => '/Runner/Filter/ExcludeGroupFilterIterator.php',
+'phpunit\\runner\\filter\\factory' => '/Runner/Filter/Factory.php',
+'phpunit\\runner\\filter\\groupfilteriterator' => '/Runner/Filter/GroupFilterIterator.php',
+'phpunit\\runner\\filter\\includegroupfilteriterator' => '/Runner/Filter/IncludeGroupFilterIterator.php',
+'phpunit\\runner\\filter\\namefilteriterator' => '/Runner/Filter/NameFilterIterator.php',
+'phpunit\\runner\\hook' => '/Runner/Hook/Hook.php',
+'phpunit\\runner\\nulltestresultcache' => '/Runner/NullTestResultCache.php',
+'phpunit\\runner\\phpttestcase' => '/Runner/PhptTestCase.php',
+'phpunit\\runner\\resultcacheextension' => '/Runner/ResultCacheExtension.php',
+'phpunit\\runner\\standardtestsuiteloader' => '/Runner/StandardTestSuiteLoader.php',
+'phpunit\\runner\\testhook' => '/Runner/Hook/TestHook.php',
+'phpunit\\runner\\testlisteneradapter' => '/Runner/Hook/TestListenerAdapter.php',
+'phpunit\\runner\\testresultcache' => '/Runner/TestResultCache.php',
+'phpunit\\runner\\testsuiteloader' => '/Runner/TestSuiteLoader.php',
+'phpunit\\runner\\testsuitesorter' => '/Runner/TestSuiteSorter.php',
+'phpunit\\runner\\version' => '/Runner/Version.php',
+'phpunit\\textUI\\command' => '/TextUI/Command.php',
+'phpunit\\textUI\\exception' => '/TextUI/Exception.php',
+'phpunit\\textUI\\help' => '/TextUI/Help.php',
+'phpunit\\textUI\\resultprinter' => '/TextUI/ResultPrinter.php',
+'phpunit\\textUI\\testrunner' => '/TextUI/TestRunner.php',
+'phpunit\\util\\annotation\\docblock' => '/Util/Annotation/DocBlock.php',
+'phpunit\\util\\annotation\\registry' => '/Util/Annotation/Registry.php',
+'phpunit\\util\\blacklist' => '/Util/Blacklist.php',
+'phpunit\\util\\color' => '/Util/Color.php',
+'phpunit\\util\\configuration' => '/Util/Configuration.php',
+'phpunit\\util\\configurationgenerator' => '/Util/ConfigurationGenerator.php',
+'phpunit\\util\\errorhandler' => '/Util/ErrorHandler.php',
+'phpunit\\util\\exception' => '/Util/Exception.php',
+'phpunit\\util\\fileloader' => '/Util/FileLoader.php',
+'phpunit\\util\\filesystem' => '/Util/Filesystem.php',
+'phpunit\\util\\filter' => '/Util/Filter.php',
+'phpunit\\util\\getopt' => '/Util/Getopt.php',
+'phpunit\\util\\globalstate' => '/Util/GlobalState.php',
+'phpunit\\util\\invaliddatasetexception' => '/Util/InvalidDataSetException.php',
+'phpunit\\util\\json' => '/Util/Json.php',
+'phpunit\\util\\log\\junit' => '/Util/Log/JUnit.php',
+'phpunit\\util\\log\\teamcity' => '/Util/Log/TeamCity.php',
+'phpunit\\util\\php\\abstractphpprocess' => '/Util/PHP/AbstractPhpProcess.php',
+'phpunit\\util\\php\\defaultphpprocess' => '/Util/PHP/DefaultPhpProcess.php',
+'phpunit\\util\\php\\windowsphpprocess' => '/Util/PHP/WindowsPhpProcess.php',
+'phpunit\\util\\printer' => '/Util/Printer.php',
+'phpunit\\util\\regularexpression' => '/Util/RegularExpression.php',
+'phpunit\\util\\teest' => '/Util/Test.php',
+'phpunit\\util\\testdox\\clitestdoxprinter' => '/Util/TestDox/CliTestDoxPrinter.php',
+'phpunit\\util\\testdox\\htmlresultprinter' => '/Util/TestDox/HtmlResultPrinter.php',
+'phpunit\\util\\testdox\\nameprettifier' => '/Util/TestDox/NamePrettifier.php',
+'phpunit\\util\\testdox\\resultprinter' => '/Util/TestDox/ResultPrinter.php',
+'phpunit\\util\\testdox\\testdoxprinter' => '/Util/TestDox/TestDoxPrinter.php',
+'phpunit\\util\\testdox\\textresultprinter' => '/Util/TestDox/TextResultPrinter.php',
+'phpunit\\util\\testdox\\xmlresultprinter' => '/Util/TestDox/XmlResultPrinter.php',
+'phpunit\\util\\texttestlistrenderer' => '/Util/TextTestListRenderer.php',
+'phpunit\\util\\type' => '/Util/Type.php',
+'phpunit\\util\\xdebugfilterscriptgenerator' => '/Util/XdebugFilterScriptGenerator.php',
+'phpunit\\util\\xml' => '/Util/Xml.php',
+'phpunit\\util\\xmltestlistrenderer' => '/Util/XmlTestListRenderer.php',
+],
+ "${include_dir}/PHPUnit"
+);
+
+// Dependencies
+\Fedora\Autoloader\Dependencies::required([
+ "${include_dir}/File/Iterator/autoload.php",
+ "${include_dir}/PHP/CodeCoverage/autoload.php",
+ "${include_dir}/PHP/Timer/autoload.php",
+ "${include_dir}/SebastianBergmann/Version/autoload.php",
+ "${include_dir}/SebastianBergmann/Diff/autoload.php",
+ "${include_dir}/SebastianBergmann/Environment/autoload.php",
+ "${include_dir}/SebastianBergmann/Exporter/autoload.php",
+ "${include_dir}/SebastianBergmann/GlobalState/autoload.php",
+ "${include_dir}/SebastianBergmann/Comparator/autoload.php",
+ "${include_dir}/SebastianBergmann/ObjectEnumerator/autoload.php",
+ "${include_dir}/SebastianBergmann/ResourceOperations/autoload.php",
+ "${include_dir}/SebastianBergmann/Type/autoload.php",
+ "${include_dir}/SebastianBergmann/Version/autoload.php",
+ "${include_dir}/Symfony/Component/Yaml/autoload.php",
+ "${include_dir}/Text/Template/autoload.php",
+ "${include_dir}/myclabs/DeepCopy/autoload.php",
+ "${include_dir}/PHPUnit/Framework/MockObject/autoload.php",
+ "${include_dir}/phpspec/Prophecy/autoload.php",
+ "${include_dir}/Doctrine/Instantiator/autoload.php",
+ "${include_dir}/PharIo/Manifest/autoload.php",
+ "${include_dir}/PharIo/Version/autoload.php",
+]);
+
diff --git a/dev-php/phpunit/phpunit-8.5.0.ebuild b/dev-php/phpunit/phpunit-8.5.0.ebuild
new file mode 100644
index 000000000000..2e9083564b31
--- /dev/null
+++ b/dev-php/phpunit/phpunit-8.5.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A PHP Unit Testing framework"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-php/File_Iterator-2.0.2
+ <dev-php/File_Iterator-3.0
+ >=dev-php/Text_Template-1.2.1
+ <dev-php/Text_Template-2.0
+ >=dev-php/PHP_CodeCoverage-7.0.7
+ <dev-php/PHP_CodeCoverage-8.0
+ >=dev-php/PHP_Timer-2.1.2
+ <dev-php/PHP_Timer-3.0
+ >=dev-php/doctrine-instantiator-1.2
+ <dev-php/doctrine-instantiator-2.0
+ >=dev-php/myclabs-deepcopy-1.9.1
+ <dev-php/myclabs-deepcopy-2.0
+ >=dev-php/phar-io-manifest-1.0.3
+ <dev-php/phar-io-manifest-2.0
+ >=dev-php/phar-io-version-2.0.1
+ <dev-php/phar-io-version-3.0
+ >=dev-php/phpspec-prophecy-1.8.1
+ <dev-php/phpspec-prophecy-2.0
+ >=dev-php/sebastian-comparator-3.0.2
+ <dev-php/sebastian-comparator-4.0
+ >=dev-php/sebastian-diff-3.0.2
+ <dev-php/sebastian-diff-4.0
+ >=dev-php/sebastian-environment-4.2.2
+ <dev-php/sebastian-environment-5.0
+ >=dev-php/sebastian-exporter-3.1.1
+ <dev-php/sebastian-exporter-4.0
+ >=dev-php/sebastian-global-state-3.0
+ <dev-php/sebastian-global-state-4.0
+ >=dev-php/sebastian-object-enumerator-3.0.3
+ <dev-php/sebastian-object-enumerator-4.0
+ >=dev-php/sebastian-resource-operations-2.0.1
+ <dev-php/sebastian-resource-operations-3.0
+ <dev-php/sebastian-type-2.0
+ <dev-php/sebastian-version-3.0
+ >=dev-lang/php-7.2:*[cli(-),json(-),unicode(-),xml(-),xmlwriter(-)]
+"
+
+src_install() {
+ insinto /usr/share/php/PHPUnit
+ doins -r src/*
+ insinto /usr/share/php/PHPUnit/vendor
+ newins "${FILESDIR}/autoload-8.5.0.php" autoload.php
+ exeinto /usr/share/php/PHPUnit
+ doexe phpunit
+ dosym ../share/php/PHPUnit/phpunit /usr/bin/phpunit
+}
+
+pkg_postinst() {
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge dev-lang/php with USE=\"json pdo sqlite mysql\"."
+}