summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-10-23 23:10:55 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-10-26 21:52:34 +0200
commita8b0c15178065b78b2b1592eeb67b85b7cc986d6 (patch)
tree740fc440fe40bdfc1f7e4149c5fa518233131e38 /dev-php
parentdev-php/pecl-memcached: drop 3.1.5-r1, 3.2.0 (diff)
downloadgentoo-a8b0c15178065b78b2b1592eeb67b85b7cc986d6.tar.gz
gentoo-a8b0c15178065b78b2b1592eeb67b85b7cc986d6.tar.bz2
gentoo-a8b0c15178065b78b2b1592eeb67b85b7cc986d6.zip
dev-php/pecl-apcu: add 5.1.22, adding php8-2
Also adjusted ebuild to match skel.ebuild. Signed-off-by: Conrad Kostecki <conikost@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/27922 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-apcu/Manifest1
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-5.1.22.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-php/pecl-apcu/Manifest b/dev-php/pecl-apcu/Manifest
index ae62b97debbb..67c21f7a3c8b 100644
--- a/dev-php/pecl-apcu/Manifest
+++ b/dev-php/pecl-apcu/Manifest
@@ -1 +1,2 @@
DIST apcu-5.1.21.tgz 92516 BLAKE2B 32d73b89bde9ef4eb01c9ad766930e87300b86776c95929607a8aaefba5043e3a7947d064416ac083ff38876fdb41bb03dab1552ac000082e54f809269b4c925 SHA512 a6ffe8349760d27cde0d86017a59a68e9639bf385e606622d807094f4e5fb305bb25b9ce00077d0856f4d223d44329f7a6314c229b62c78d8e2b085593c92bb3
+DIST apcu-5.1.22.tgz 93926 BLAKE2B abc3b27c4224da14b6438df9243f6b7b8245102f7eee0208daf1317bead5463d8f454e33536b8c949a2825140487faf9bb79745180a26e1f0015494e0986acb9 SHA512 8f2f4292679bc359ea680ecaf397d69de32bf67d57d719a4839a026ab1b96d5ec4725e92c5c0d1972a117a7cd3d3c456a1f4ec03192fda4657e685de60b9e93e
diff --git a/dev-php/pecl-apcu/pecl-apcu-5.1.22.ebuild b/dev-php/pecl-apcu/pecl-apcu-5.1.22.ebuild
new file mode 100644
index 000000000000..ee48a184ed83
--- /dev/null
+++ b/dev-php/pecl-apcu/pecl-apcu-5.1.22.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PHP_EXT_INI="yes"
+PHP_EXT_NAME="apcu"
+PHP_EXT_ZENDEXT="no"
+USE_PHP="php7-4 php8-0 php8-1 php8-2"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="Stripped down version of APC supporting only user cache"
+
+LICENSE="PHP-3.01"
+SLOT="7"
+KEYWORDS="amd64 ~arm ~arm64 ~x86"
+
+LOCKS="pthreadmutex pthreadrw spinlock semaphore"
+LUSE=""
+for l in ${LOCKS}; do
+ LUSE+="lock-${l} "
+done
+IUSE="+mmap ${LUSE/lock-pthreadrw/+lock-pthreadrw}"
+REQUIRED_USE="^^ ( $LUSE )"
+
+DOCS=( NOTICE README.md TECHNOTES.txt )
+
+src_prepare() {
+ php-ext-source-r3_src_prepare
+
+ # Remove broken tests from php 7.4 due to trivial output differences
+ if use php_targets_php7-4 ; then
+ php_init_slot_env "php7.4"
+ rm "${PHP_EXT_S}"/tests/apc_entry_00{2,3}.phpt || die
+ fi
+}
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-apcu
+ $(use_enable mmap apcu-mmap)
+ $(use_enable lock-spinlock apcu-spinlocks)
+ )
+
+ # Broken upstream autoconf test disables if present at all
+ use lock-pthreadrw || PHP_EXT_ECONF_ARGS+=( --disable-apcu-rwlocks )
+
+ php-ext-source-r3_src_configure
+}
+
+src_install() {
+ php-ext-pecl-r3_src_install
+
+ insinto /usr/share/php7/apcu
+ doins apc.php
+}
+
+pkg_postinst() {
+ elog "The apc.php file shipped with this release of pecl-apcu"
+ elog "was installed to ${EPREFIX}/usr/share/php7/apcu/."
+}