summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-12-05 12:59:31 -0500
committerBrian Evans <grknight@gentoo.org>2019-12-05 12:59:31 -0500
commitaad5c02f879275e1b48c2fe74604caf16fd7189c (patch)
tree611f765017df6a1b398ff284298f0b1c03d95560 /dev-php
parentdev-util/strace: do not copy CFLAGS to CFLAGS_FOR_{M32,MX32} (diff)
downloadgentoo-aad5c02f879275e1b48c2fe74604caf16fd7189c.tar.gz
gentoo-aad5c02f879275e1b48c2fe74604caf16fd7189c.tar.bz2
gentoo-aad5c02f879275e1b48c2fe74604caf16fd7189c.zip
dev-php/pecl-raphf: Mark 2.0.0-r2 stable for amd64 and x86
Tested by maintainer Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild b/dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild
index f28c7a6bb551..e594718f2c51 100644
--- a/dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild
+++ b/dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild
@@ -9,14 +9,14 @@ PHP_EXT_ZENDEXT="no"
PHP_EXT_ECONF_ARGS=""
PHP_INI_NAME="30-${PHP_EXT_NAME}"
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
+USE_PHP="php5-6 php7-1 php7-2 php7-3"
inherit php-ext-pecl-r3
# Only really build for 7.x
USE_PHP="php7-1 php7-2 php7-3"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
DESCRIPTION="A reusable, persistent handle and resource factory API"
LICENSE="BSD-2"
@@ -25,6 +25,9 @@ IUSE=""
RDEPEND="php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6] )"
+# Tests need pecl-http, which needs this
+RESTRICT="test"
+
src_prepare() {
if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3; then
php-ext-source-r3_src_prepare