summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-01-30 17:42:40 -0500
committerMichael Orlitzky <mjo@gentoo.org>2016-02-03 17:10:28 -0500
commitbbf63155bedcf2b2cbd58a881bd717c4f4b86467 (patch)
treebe248a35d92c24aa92343242b7b5f7c5f3799d99 /dev-php
parentphp-pear-r1.eclass: add support for EAPI=6 and clean up the EAPI check. (diff)
downloadgentoo-bbf63155bedcf2b2cbd58a881bd717c4f4b86467.tar.gz
gentoo-bbf63155bedcf2b2cbd58a881bd717c4f4b86467.tar.bz2
gentoo-bbf63155bedcf2b2cbd58a881bd717c4f4b86467.zip
dev-php/PEAR-DB_DataObject: add version 1.11.5.
This version bump was mostly straightforward, but the ebuild was ported to EAPI=6 and its dependencies were cleaned up as well. A simpler pattern was used to replace the existing "sed" invocation. The LICENSE was also updated per the homepage. Gentoo-Bug: 573242 Reported-By: Hanno Böck Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-DB_DataObject/Manifest1
-rw-r--r--dev-php/PEAR-DB_DataObject/PEAR-DB_DataObject-1.11.5.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/PEAR-DB_DataObject/Manifest b/dev-php/PEAR-DB_DataObject/Manifest
index a13eb30f8b52..5b5b89c8454c 100644
--- a/dev-php/PEAR-DB_DataObject/Manifest
+++ b/dev-php/PEAR-DB_DataObject/Manifest
@@ -1 +1,2 @@
DIST DB_DataObject-1.11.3.tgz 81873 SHA256 5fa1ce2d3d2543a5b9e8f825a2c9a409201978b0f6c45da1f9dadfe58ac47d2b SHA512 bf74b99b6d28e8c5074dd9058ad6624ed93cd4578164d71fcf2c70070a81f5bb5dfc46d11d5a1408ad5bac12ac6d36cd47dbe102b16ffbf9c091153e9e400d8f WHIRLPOOL 3189f3238afc0d7087ced6c1b1bd91ecf99b009f03e17e907d68404c7d5e06f6ebeda0d5b3ef7235802fd18062ae330ec974b5121de17078521cec2210a1e0c9
+DIST DB_DataObject-1.11.5.tgz 83878 SHA256 0157d3197c28b33d41c069b7f0ed8d2651fe2377e83a0a7b9f1b7a47a4f31b05 SHA512 bc8c5d0994fba78c6f8137682da87018e7660ceb39f5583aabf424509bf0ab263b8f32f6676821acaf69ed991778ad85f5f3fc156799c0811b2ec39546688bc6 WHIRLPOOL 64e1eea3a33e83d307a5059e7f770fb9e16b0c67ac4feb6962e0f7c2caf102a160645005581c9cf828f0013829fe133a2fe8dc66356039283a3b3908f3cc3472
diff --git a/dev-php/PEAR-DB_DataObject/PEAR-DB_DataObject-1.11.5.ebuild b/dev-php/PEAR-DB_DataObject/PEAR-DB_DataObject-1.11.5.ebuild
new file mode 100644
index 000000000000..87d2dae044a7
--- /dev/null
+++ b/dev-php/PEAR-DB_DataObject/PEAR-DB_DataObject-1.11.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit php-pear-r1
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="SQL builder and data modeling layer"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="minimal"
+
+# The MDB2/DB dependencies are listed as "optional," but really, you
+# need one or the other. Prefer the newer MDB2 to the deprecated DB.
+DEPEND=""
+RDEPEND="|| ( dev-php/PEAR-MDB2 dev-php/PEAR-DB )
+ dev-php/PEAR-Date
+ !minimal? ( dev-php/PEAR-Validate )"
+
+src_prepare() {
+ # Don't install this batch file -- it winds up in ${EPREFIX}/usr/bin.
+ # Delete the line that mentions it from package.xml.
+ sed -e '/DB_DataObject_createTables\.bat/d' \
+ -i "${WORKDIR}/package.xml" \
+ || die "failed to remove batch file from package.xml"
+
+ eapply_user
+}