summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-06 16:32:49 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-06 16:34:41 +0200
commitbe93e65d9dd3068eecc12329ec284ca40912be9b (patch)
tree66debfc35913c04ee77fd2125e2a642a688742b8 /dev-php
parentdev-php/pecl-mongodb: bump to v1.8.0 (diff)
downloadgentoo-be93e65d9dd3068eecc12329ec284ca40912be9b.tar.gz
gentoo-be93e65d9dd3068eecc12329ec284ca40912be9b.tar.bz2
gentoo-be93e65d9dd3068eecc12329ec284ca40912be9b.zip
dev-php/PHPMailer: bump to v6.1.7
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PHPMailer/Manifest1
-rw-r--r--dev-php/PHPMailer/PHPMailer-6.1.7.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-php/PHPMailer/Manifest b/dev-php/PHPMailer/Manifest
index 156f23296ca7..c6730556d128 100644
--- a/dev-php/PHPMailer/Manifest
+++ b/dev-php/PHPMailer/Manifest
@@ -1,2 +1,3 @@
DIST PHPMailer-5.2.28.tar.gz 159284 BLAKE2B 866a38c60ac55cbd8aefec5ad82211575e672578ddff1af435e676c7058b0a090884f3e5f2c1e6f30c94b01e393f982f644e578ea22c931ffb8a93be717e379b SHA512 c2dd762b8958d1dc68fec52d7daae7337e05cadcbcf9e67c27247c808877cf3132e80cf6d4c9c577f8ad9203e433282e45f2166bccce025bcc4477724eb7036f
DIST PHPMailer-6.1.6.tar.gz 94769 BLAKE2B 6689f4429c0847de41016325553d58d544f78d5f8a94d9014841435a3cf161e4e10b14fe2cbb61c737bf75d87f2dc4cde66885c06a0b6992a472f0f46fe5dd6b SHA512 25530e6c5513e89729a5b253565143a5a9a35ee5f7813637eee18ca1d604cb83625f7beb106e56536f681d7ec4332fcd3cddcac5da7c73f730db1b056ba5b2e4
+DIST PHPMailer-6.1.7.tar.gz 95102 BLAKE2B 8a1a09aa8f1c82900d881cf82e4a44705afbabc2f38b7bcf8b069a23c426f690dfbebd30c27a30dfbd8a3ad10e75e88fab4fa064bd44308b837455b84a41cad9 SHA512 4b37e11bb99966b8151b64a469125f249091c9b57ef729549735f37869fbaf1a1fb1a3f9d19822c824e909e8b53b696d3cb0d5180683e94968145a968622c2e8
diff --git a/dev-php/PHPMailer/PHPMailer-6.1.7.ebuild b/dev-php/PHPMailer/PHPMailer-6.1.7.ebuild
new file mode 100644
index 000000000000..e27c5fd93328
--- /dev/null
+++ b/dev-php/PHPMailer/PHPMailer-6.1.7.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Full-featured email creation and transfer class for PHP"
+HOMEPAGE="https://github.com/PHPMailer/PHPMailer"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# To help out the Composer children, the tests and examples are missing
+# from the release tarballs.
+IUSE="doc idn ssl"
+
+# The ctype and filter extensions get used unconditionally, with no
+# fallback and no "extension missing" exception. All of the other
+# extensions are technically optional, depending on how you use
+# PHPMailer and whether or not you're willing to settle for fallback
+# implementations.
+#
+# The insane dependency string is to prevent the ctype and filter
+# extensions from being provided by one version (i.e. slot) of PHP,
+# while intl and unicode are provided by another.
+RDEPEND="
+ ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,ssl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter,ssl] )
+ )
+ !ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter] )
+ )"
+BDEPEND="doc? ( dev-php/phpDocumentor )"
+
+src_prepare() {
+ # OAuth.php relies on a (now non-nonexistent) autoloader. We remove
+ # it early so that we don't generate documentation for it later on.
+ rm src/OAuth.php || die 'failed to remove src/OAuth.php'
+ eapply_user
+}
+
+src_compile() {
+ if use doc; then
+ phpdoc --filename="src/*.php" \
+ --target="./html" \
+ --cache-folder="${T}" \
+ --title="${PN}" \
+ --sourcecode \
+ --force \
+ --progressbar \
+ || die "failed to generate API documentation"
+ fi
+}
+
+src_install() {
+ # The PHPMailer class loads its language files
+ # using a relative path, so we need to keep the "src" here.
+ insinto "/usr/share/php/${PN}"
+ doins -r language src
+
+ dodoc README.md SECURITY.md
+ use doc && dodoc -r html/*
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "Upstream no longer provides an autoloader, so you will need"
+ elog "to include each source file (for example: PHPMailer.php,"
+ elog "Exception.php,...) that you need."
+}