summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-09-30 18:27:57 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-09-30 20:03:43 +0200
commitc2fb607934d8e7b737acc75e0ab8da1091ef1c33 (patch)
tree6858032f2083e97933dfee64b7425c00be73bc85 /dev-php
parentdev-php/PEAR-Archive_Tar: bump to v1.4.10 (diff)
downloadgentoo-c2fb607934d8e7b737acc75e0ab8da1091ef1c33.tar.gz
gentoo-c2fb607934d8e7b737acc75e0ab8da1091ef1c33.tar.bz2
gentoo-c2fb607934d8e7b737acc75e0ab8da1091ef1c33.zip
dev-php/pecl-mailparse: bump to v3.1.1
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-mailparse/Manifest1
-rw-r--r--dev-php/pecl-mailparse/pecl-mailparse-3.1.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/pecl-mailparse/Manifest b/dev-php/pecl-mailparse/Manifest
index 20ab4b78d427..d1feeff56a51 100644
--- a/dev-php/pecl-mailparse/Manifest
+++ b/dev-php/pecl-mailparse/Manifest
@@ -1,2 +1,3 @@
DIST mailparse-3.0.4.tgz 940428 BLAKE2B e3e33ecfa953766744a6980e0c681bb9b473d4cbf46179c8099f5483e8da46f47bba30d953d1c3629ea6d1719fcdfb0cca8536de3c3159a979cb7b2cde9ff9a2 SHA512 71eaebc1dc8a4698e60e170facaba16a5a9314bcb21c375b2f9a3069d7f1da819bfabc736b244e3f87131149d4efd9363120e77d8a078a0ede15113123d13ce3
DIST mailparse-3.1.0.tgz 941058 BLAKE2B 050b16d90ba2cb4443df05eadb85d9835d1af8940bbb348cd5c6dd180f706519f483e9af5fe57ed35a5ea8e66a9e8a868848e7f2a1eca397c247e7f4aa1c110f SHA512 5a2a0786fc62fc47a60dcd52158ed86a1a58a26dc764b62abd763f784553f853c6644e4de76c85ad9133c8359d040c546c662b5f838ff7a5c88307aa21a589ca
+DIST mailparse-3.1.1.tgz 941192 BLAKE2B 00b5a506031cd03439e3d67172c17aeeb6af3b950694251f7654007642bf80fff3cda900fc97ba177b91ca970e47416132080793ce64d8038e7aecbf2fdaf6c0 SHA512 01ddb8d4d27a74c14f70b02b49322c60fc79affab374205fee91b9da21e5148e08dba024f6bc620e4f26c2c937675e09092c52ca69172d2f7797c3e2bf374bee
diff --git a/dev-php/pecl-mailparse/pecl-mailparse-3.1.1.ebuild b/dev-php/pecl-mailparse/pecl-mailparse-3.1.1.ebuild
new file mode 100644
index 000000000000..cb73196e10c0
--- /dev/null
+++ b/dev-php/pecl-mailparse/pecl-mailparse-3.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WANT_AUTOMAKE="none"
+PHP_EXT_NAME="mailparse"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_ECONF_ARGS=""
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
+PHP_EXT_NEEDED_USE="unicode"
+DOCS=( README.md )
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="PHP extension for parsing and working with RFC822 and MIME compliant messages"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE=""
+
+src_prepare() {
+ # Missing test source files in archive. Fixed upstream in next release.
+ rm tests/011.phpt tests/bug001.phpt || die
+ php-ext-source-r3_src_prepare
+}