summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTill Schäfer <till2.schaefer@uni-dortmund.de>2018-01-11 16:30:41 +0100
committerMichael Orlitzky <mjo@gentoo.org>2018-01-12 19:33:31 -0500
commite2e8840531473958af2f07a0ab684a4d56d6029b (patch)
tree7f113dc2cd83a97ba7cbc49c5270fb465e5331a1 /dev-php
parentprofiles: Mask net-ftp/qshare and net-ftp/scythia for removal (diff)
downloadgentoo-e2e8840531473958af2f07a0ab684a4d56d6029b.tar.gz
gentoo-e2e8840531473958af2f07a0ab684a4d56d6029b.tar.bz2
gentoo-e2e8840531473958af2f07a0ab684a4d56d6029b.zip
dev-php/awl: bump to 0.59
drop doc useflag since generation is broken Bug: https://bugs.gentoo.org/573218 Package-Manager: Portage-2.3.13, Repoman-2.3.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/awl/Manifest1
-rw-r--r--dev-php/awl/awl-0.59.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-php/awl/Manifest b/dev-php/awl/Manifest
index 50f8c1d6d663..4ef39b86d5b6 100644
--- a/dev-php/awl/Manifest
+++ b/dev-php/awl/Manifest
@@ -1 +1,2 @@
DIST awl-0.56.tar.gz 769208 BLAKE2B 08513675d8d26fab26429a6e51cfd7dc3b00aa7cec6538789e6bbd2853989bf563ffba0df3cda61359f30ab672a74798251213e58423cbc4a77185ffd74e6716 SHA512 6336d6f938330eee0b51f04665776269d974086ba56a3c8f4b7f53e7e17b637d899e9b329aeba3dcd690673a1a95a8cf03ae8417ebb9f356294314790915886a
+DIST awl-0.59.tar.gz 601449 BLAKE2B 606c52bdad06e6fa130fd20f7da25bc75c7357c81c1d34d88bb62c43b56857eb95492581b8845ff97416d94d64135ccaa5bcba0b3989a115156ade05bc1b26b8 SHA512 d3e82e7f3269c1c02c801628498768ec94a8d215b719369e8ee997d67c86c5e4e780571852a077511ffffbe91ade1d05bfc60ee03624fbaada1ce23f7335d3e3
diff --git a/dev-php/awl/awl-0.59.ebuild b/dev-php/awl/awl-0.59.ebuild
new file mode 100644
index 000000000000..24b33af893f7
--- /dev/null
+++ b/dev-php/awl/awl-0.59.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vcs-snapshot
+
+DESCRIPTION="Andrew McMillan's Web Libraries"
+HOMEPAGE="https://gitlab.com/davical-project/awl"
+SRC_URI="${HOMEPAGE}/repository/archive.tar.gz?ref=r${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-php/phpunit )"
+RDEPEND="dev-lang/php:*[pdo,postgres,xml]"
+
+src_compile() {
+ :
+}
+
+src_test() {
+ phpunit tests/ || die "test suite failed"
+}
+
+src_install() {
+ dodoc debian/changelog
+ insinto /usr/share/php/${PN}
+ doins -r dba inc
+}