summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-02-22 15:11:59 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-02-22 15:11:59 +0100
commite7bb7f590906bcade107391ab026a3057bcf4eef (patch)
treef3c65cb7a688bca6b69be1e5fd6ceba6d5ff5d5c /dev-php
parentdev-util/checkbashisms: bump to v2.19.3 (diff)
downloadgentoo-e7bb7f590906bcade107391ab026a3057bcf4eef.tar.gz
gentoo-e7bb7f590906bcade107391ab026a3057bcf4eef.tar.bz2
gentoo-e7bb7f590906bcade107391ab026a3057bcf4eef.zip
dev-php/pecl-apcu: bump to v5.1.17
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-apcu/Manifest1
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-5.1.17.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-php/pecl-apcu/Manifest b/dev-php/pecl-apcu/Manifest
index 3da4537b3405..8e2142410ffb 100644
--- a/dev-php/pecl-apcu/Manifest
+++ b/dev-php/pecl-apcu/Manifest
@@ -3,5 +3,6 @@ DIST apcu-5.1.10.tgz 111937 BLAKE2B 87bf86b43a775c38b232e4acd876f5c63628fc095747
DIST apcu-5.1.11.tgz 105462 BLAKE2B 37ff632555e1bca51951db3021a4108a1de491b1bae2b12daed80e5d2d4651737cad744023c62956779395198accf33290c0c3b81b6abfc7bb54337a1a23e082 SHA512 2c284bbe84012030cc5c24ccf903c3abee995af549616c10211dbd5e463a5f37a3f27a5982127db81787a64345597a10be495380b844ce6204dc57c8b058bb88
DIST apcu-5.1.12.tgz 105890 BLAKE2B 110a56ed1da8e33bd39c9d694007acdca2deb42219ae5d31b57296ff3729bab3fdbc508965b2cd0fccc425b2c2fea9249933cd7f45586beeee7cd3bd38ef2473 SHA512 f53b7840d5aecfc899e3e878f0bb9a5dc4a83628543963c20c25ce2b2a2adf14dd40d39a6a2014c139962453e0e9e5038fca7b1d0be205c0b9b2aa6e3fefb054
DIST apcu-5.1.16.tgz 94032 BLAKE2B 3676cfaad796f565b63fa882fad79ed2fc8de383d364ff24369556761e21f7091ebd7064ac8e0815f283e839bc95ca88aced83d882b622d3a4297af46dc0da72 SHA512 cda2b61540b786cdecc09a2c1f77c5bf91cc118ac97fa929f1d4c3c63d29969397cf3ee37691a86e7bd7784411046df5d93efe37b4cc0c1ce903dfa7dc7dce89
+DIST apcu-5.1.17.tgz 94814 BLAKE2B 2e49f08b9445f04fd036bc949c9099ee045c3ecd460b323e371a4906fdef77f8d3e7d338af14fe3e116a94aa548c7fb79cc0003556ed739e258370095cbec075 SHA512 7f6a6cd927ed4ff251497c2c79e8d832d1a44ddd59abdb175886d3c12ea27f26142e6b851ac5bb5acb49a0e3a998e9741ba0ff03310f51b9cd188cdf6cf12793
DIST apcu-5.1.8.tgz 111260 BLAKE2B eb41b1af33500ed9ddbbcb5e1a92884af4b356e16cf76c70f75a8853522cc91af1c156cc0bbd464fce539a138bf4e2ead5101810223b0f1bb91cd062850ef08e SHA512 4f377389e713bcae5534c64ea28f72c20ab2176aa758188c4d956c1f2370be49bc33dd2a1db43941fff5344a164aaeebc4e73e6d579f62d17334bcc520171526
DIST apcu-5.1.9.tgz 111049 BLAKE2B c7138f65d73a056e4a34972098c2b543ad6d96d0d8215e82757c457cc8938af48fea842e006c79c83deee4060cdc94047764930592eef03c5f347abeb7730897 SHA512 3e9b29a293b5bfb29283dd650907bfb9f31a1cb99ef908021d3869c3e3ae4051a2c45aab27275e90b0a2fa94c35cc9e170637dc539184d955f3f13dc09cba060
diff --git a/dev-php/pecl-apcu/pecl-apcu-5.1.17.ebuild b/dev-php/pecl-apcu/pecl-apcu-5.1.17.ebuild
new file mode 100644
index 000000000000..7a61f40da796
--- /dev/null
+++ b/dev-php/pecl-apcu/pecl-apcu-5.1.17.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="apcu"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( NOTICE README.md TECHNOTES.txt )
+
+# Define 5.6 here so we get the USE and REQUIRED_USE from the eclass
+# This allows us to depend on the other slot
+USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
+
+inherit php-ext-pecl-r3
+
+# However, we only really build for 7.x; so redefine it here
+USE_PHP="php7-0 php7-1 php7-2 php7-3"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Stripped down version of APC supporting only user cache"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE="+mmap"
+
+DEPEND=""
+RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-apcu:0[php_targets_php5-6] )"
+
+LOCKS="pthreadmutex pthreadrw spinlock semaphore"
+
+LUSE=""
+for l in ${LOCKS}; do
+ LUSE+="lock_${l} "
+done
+
+IUSE+=" ${LUSE/lock_pthreadrw/+lock_pthreadrw}"
+
+REQUIRED_USE="^^ ( $LUSE )"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ php-ext-source-r3_src_prepare
+ else
+ eapply_user
+ fi
+}
+
+src_configure() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-apcu
+ $(use_enable mmap apcu-mmap)
+ $(use_enable lock_pthreadrw apcu-rwlocks)
+ $(use_enable lock_spinlock apcu-spinlocks)
+ )
+
+ php-ext-source-r3_src_configure
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ php-ext-pecl-r3_src_install
+
+ insinto /usr/share/php7/apcu
+ doins apc.php
+ fi
+}
+
+pkg_postinst() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ elog "The apc.php file shipped with this release of pecl-apcu was"
+ elog "installed into ${EPREFIX}/usr/share/php7/apcu/."
+ elog
+ elog "If you depend on the apc_* functions,"
+ elog "please install dev-php/pecl-apcu_bc as this extension no longer"
+ elog "provides backwards compatibility."
+ fi
+}