summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-09-22 10:36:23 -0400
committerBrian Evans <grknight@gentoo.org>2021-09-22 10:36:23 -0400
commite86e1147c388c52fc38373db284139edcf7e4087 (patch)
tree1f20718fa584a19259142d2a2347e9ce7fa7d4e9 /dev-php
parentmedia-sound/pavucontrol: keyword ~riscv (diff)
downloadgentoo-e86e1147c388c52fc38373db284139edcf7e4087.tar.gz
gentoo-e86e1147c388c52fc38373db284139edcf7e4087.tar.bz2
gentoo-e86e1147c388c52fc38373db284139edcf7e4087.zip
dev-php/pecl-http: Version bump for 4.2.1
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-http/Manifest1
-rw-r--r--dev-php/pecl-http/pecl-http-4.2.1.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-php/pecl-http/Manifest b/dev-php/pecl-http/Manifest
index dc929ad0735f..ec99a7a950a5 100644
--- a/dev-php/pecl-http/Manifest
+++ b/dev-php/pecl-http/Manifest
@@ -2,3 +2,4 @@ DIST pecl_http-3.2.1.tgz 221244 BLAKE2B b6581829fb8a800e24ccedd4d0f3efbaf558850b
DIST pecl_http-3.2.4.tgz 220631 BLAKE2B 996236cf9dd2f7d9bfaf046306e99c3ccf778261df19df8fd828b5811798f784841d89a6890e7347bd20cc6da71c966ea3ac9b17bf058e0bb766db7e1a8a6c49 SHA512 59c41d57c94a6e50e2f0b261130a24791b2845246f783b55e7f644f9a897d3650da364c5b38a860761b4a23f9266ed05000d6348bae2a7941e59d6bf5fb61a9e
DIST pecl_http-4.0.0.tgz 218259 BLAKE2B c9f5973686fd4db95a24dd4c50f217b93becc6a439066a395b0b7fec6e977154e5ae8f2261414458aed8e4a9d1281f44da2ecc67a05127610579f5be91196a88 SHA512 268b569c23f10ed72fe3c84fc5e5bf526c3e5ac345ca0556a24fbd01ce95da468d4e9aac6300d058001534ab826836793bf901e9560b744f1e20d7059be2ec79
DIST pecl_http-4.1.0.tgz 220349 BLAKE2B 71152ee20930843636d90547339270fecf5569cb9a252a516c8150a134bf75fcb88b4fcfd129af1ca1366f4df775653b4dcdddbf0eb02426625550c1b1a0b483 SHA512 653c1dd8ec6dc738ce2dbf235a3c92522858e17ab9c0d00dd75a51bcfeb836f3fb02a6040b8b67d8d6839055286599958db844891686ca70c36031500be0bc1c
+DIST pecl_http-4.2.1.tgz 224452 BLAKE2B 58d2e1159aa64b9893b2b8b67c8444801308084ac13a743760c25cb3d0456fb586f69dc6b9e77db53341e4e9e45ce68f954c47b4e2663afe86de67d63db5e8e2 SHA512 2ad7e57fae313a7b46ba88e528e124ac9d83804827131a6ef478ccf3cf5883dec2d928b8ceb377ee7f5947c76f24d640d77533a9946612419e526786a79877e6
diff --git a/dev-php/pecl-http/pecl-http-4.2.1.ebuild b/dev-php/pecl-http/pecl-http-4.2.1.ebuild
new file mode 100644
index 000000000000..00f8de1189da
--- /dev/null
+++ b/dev-php/pecl-http/pecl-http-4.2.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_INI_NAME="50-http"
+
+USE_PHP="php7-3 php7-4 php8-0"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php8-0"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP"
+LICENSE="BSD-2 MIT"
+SLOT="8"
+IUSE="ssl curl_ssl_gnutls curl_ssl_nss +curl_ssl_openssl"
+
+COMMON_DEPEND="app-arch/brotli:=
+ dev-libs/libevent
+ >=dev-php/pecl-raphf-2.0.1:7[php_targets_php8-0(-)?]
+ net-dns/libidn2
+ sys-libs/zlib
+ ssl? ( net-misc/curl[ssl,curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=] )
+ !ssl? ( net-misc/curl[-ssl] )
+"
+DEPEND="
+ php_targets_php8-0? ( ${COMMON_DEPEND} dev-lang/php:8.0[session(-),iconv(-)] )"
+RDEPEND="${DEPEND}
+ php_targets_php7-3? ( dev-php/pecl-http:7[php_targets_php7-3(-)] )
+ php_targets_php7-4? ( dev-php/pecl-http:7[php_targets_php7-4(-)] )"
+
+PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps --without-http-libidn-dir )
+
+src_prepare() {
+ if use php_targets_php8-0 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+
+ # Respect LDFLAGS, bug 727134
+ export EXTRA_LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ # Cannot use eclass function due to required modules
+ # All tests SKIP otherwise
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+
+ # Link in required modules for testing
+ ln -s "${EXT_DIR}/raphf.so" "modules/raphf.so" || die
+
+ sed -i \
+ 's/PHP_TEST_SHARED_EXTENSIONS)/PHP_TEST_SHARED_EXTENSIONS) -d extension=raphf/' \
+ Makefile || die
+
+ SKIP_ONLINE_TESTS=yes NO_INTERACTION="yes" emake test
+
+ # Clean up testing links
+ rm modules/raphf.so || die
+ done
+}
+
+src_install() {
+ if use php_targets_php8-0 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}