summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-01-06 00:16:34 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-01-06 00:20:18 +0100
commited746f7ed53eba312fa893ed20be156eefb231f1 (patch)
tree4af92117a898eb08bbebb3faa73f2200ab0c46c0 /dev-php
parentdev-php/phpunit: bump to v8.5.1 (diff)
downloadgentoo-ed746f7ed53eba312fa893ed20be156eefb231f1.tar.gz
gentoo-ed746f7ed53eba312fa893ed20be156eefb231f1.tar.bz2
gentoo-ed746f7ed53eba312fa893ed20be156eefb231f1.zip
dev-php/swoole: bump to v4.4.14
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/swoole/Manifest1
-rw-r--r--dev-php/swoole/swoole-4.4.14.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-php/swoole/Manifest b/dev-php/swoole/Manifest
index 2262d4f174e6..c0a2822b6995 100644
--- a/dev-php/swoole/Manifest
+++ b/dev-php/swoole/Manifest
@@ -1,2 +1,3 @@
DIST swoole-4.2.13.tgz 1305634 BLAKE2B bb30180f7ca7b024a2aab8aff1149f6b19035315c9518dfc9e9e2e02acde09aa4cd09fbe146aefd39fc09c25af68347a5c188ca8a21677926b1adea5b549858b SHA512 f2438ce761766d20a24279a2d6f2094c718324585b1d396344f64e8a4facc1cc025a3afb2deff3b1accd5266763bdaa0a2b15e831ea4b9bdb107c83b0046636d
DIST swoole-4.4.12.tgz 1436554 BLAKE2B cc9e64e108aa9b393265708a6922f53824c2e9941c0f47f4f6aacf93239829381cdf4625af8f30e2ca8ceb1663047c6be8b2d7808dbc29d27100135288f7ac85 SHA512 8899bb048b85c048903c80fe1af045ea4f82a25b3b4fd9995d51c8a2ab144306f9f5651276776e3f6a29c83322fb0aeee2822d131247070fe9e2e87b26f2e0e9
+DIST swoole-4.4.14.tgz 1440095 BLAKE2B 8a893604a84f750b95bb63a3c6ce9869a80a700b58e744e0da588dcdb88b9d9ae8fa5b73548cc182e255d7fe4e49139c3da9bcec40a54af94c35d355ee4cbfe0 SHA512 73b598069d38dcc3201a31fdd93c1bcf0ce31ab5399bade8c31f6decae25ef6e9c0aefe0412409158c1dd0fe502751c8e669e0a34561cb1b36448366708572c6
diff --git a/dev-php/swoole/swoole-4.4.14.ebuild b/dev-php/swoole/swoole-4.4.14.ebuild
new file mode 100644
index 000000000000..146edf124e9f
--- /dev/null
+++ b/dev-php/swoole/swoole-4.4.14.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="swoole"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_SAPIS="cli"
+DOCS=( README.md )
+
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
+
+inherit php-ext-pecl-r3
+
+HOMEPAGE="https://www.swoole.co.uk"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Event-driven asynchronous & concurrent & coroutine networking engine"
+LICENSE="Apache-2.0"
+SLOT="0"
+# Tests can hang. Disable until this no longer happens
+RESTRICT="test"
+
+DEPEND="
+ app-arch/brotli:0=
+ dev-libs/libaio
+ dev-libs/boost:0=
+ dev-libs/libpcre
+ sys-libs/zlib:0=
+ http2? ( net-libs/nghttp2:0= )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
+ php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
+ php_targets_php7-3? ( dev-lang/php:7.3[cli,sockets?] )
+ php_targets_php7-4? ( dev-lang/php:7.4[cli,sockets?] )
+ mysql? (
+ php_targets_php7-1? ( dev-lang/php:7.1[mysql,mysqli(+)] )
+ php_targets_php7-2? ( dev-lang/php:7.2[mysql,mysqli(+)] )
+ php_targets_php7-3? ( dev-lang/php:7.3[mysql,mysqli(+)] )
+ php_targets_php7-4? ( dev-lang/php:7.4[mysql,mysqli(+)] )
+ )
+"
+
+RDEPEND="${DEPEND}"
+
+IUSE="debug http2 libressl mysql sockets ssl"
+
+src_configure() {
+ # JEMalloc not included as it refuses to find a ${EROOT}/usr/includes/jemalloc subdirectory
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-swoole
+ $(use_enable debug)
+ $(use_enable http2)
+ $(use_enable mysql mysqlnd)
+ $(use_enable ssl openssl)
+ $(use_with ssl openssl-dir "${EROOT}/usr")
+ $(use_enable sockets)
+ )
+
+ php-ext-source-r3_src_configure
+}
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ [[ -f tests/template.phpt ]] && rm tests/template.phpt
+ SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
+ done
+}