summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-29 20:33:51 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-29 20:35:10 +0100
commitf5485b7a5dbfd68ef35ed95da1cbe1a849c308c1 (patch)
tree78b29af0df3e9a3cfea6f60e0b96cc693c2137e4 /dev-php
parentdev-php/swoole-async: initial import of v4.4.12 (diff)
downloadgentoo-f5485b7a5dbfd68ef35ed95da1cbe1a849c308c1.tar.gz
gentoo-f5485b7a5dbfd68ef35ed95da1cbe1a849c308c1.tar.bz2
gentoo-f5485b7a5dbfd68ef35ed95da1cbe1a849c308c1.zip
dev-php/realpath_turbo: initial import of v2.0.0
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/realpath_turbo/Manifest1
-rw-r--r--dev-php/realpath_turbo/metadata.xml15
-rw-r--r--dev-php/realpath_turbo/realpath_turbo-2.0.0.ebuild28
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-php/realpath_turbo/Manifest b/dev-php/realpath_turbo/Manifest
new file mode 100644
index 000000000000..edbb9d2adfb3
--- /dev/null
+++ b/dev-php/realpath_turbo/Manifest
@@ -0,0 +1 @@
+DIST realpath_turbo-2.0.0.tar.bz2 9106 BLAKE2B 3275397ab72def1b120d2df1bfe6c233283754539b2ea7dfd558a0773d2f094f9f6b31850a516b883af470cd04d4ebb9d5a7d8492608169a797d1562c7236d11 SHA512 03a03d4a3a067ffac61222c4d71031ab9e289b745fd3b158b5b723f3abf1ad7bb1f691904e3f7b53a98c970f1b0f7c4fe558a4de696aac77d0f9a0f99159fb30
diff --git a/dev-php/realpath_turbo/metadata.xml b/dev-php/realpath_turbo/metadata.xml
new file mode 100644
index 000000000000..9c672a724777
--- /dev/null
+++ b/dev-php/realpath_turbo/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/Whissi/realpath_turbo/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/realpath_turbo/realpath_turbo-2.0.0.ebuild b/dev-php/realpath_turbo/realpath_turbo-2.0.0.ebuild
new file mode 100644
index 000000000000..629ec768de12
--- /dev/null
+++ b/dev-php/realpath_turbo/realpath_turbo-2.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="realpath_turbo"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6 php7-1 php7-2 php7-3 php7-4"
+
+inherit php-ext-source-r3
+
+MY_PV="${PV/_/}"
+
+DESCRIPTION="PHP extension to re-enable realpath cache when using open_basedir restriction"
+HOMEPAGE="https://github.com/Whissi/${PN}/"
+SRC_URI="https://github.com/Whissi/${PN}/releases/download/v${MY_PV}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DOCS=( ChangeLog CREDITS LICENSE README.md )