summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-03-06 15:32:24 -0500
committerBrian Evans <grknight@gentoo.org>2018-03-06 15:32:24 -0500
commitff87051bd9066984b49c9b3b9bd65c4622f828de (patch)
treea3a779be1f821826276a65f0eeb94c29269ee13a /dev-php
parentx11-base/xorg-server: Add upstream patch to fix crash (diff)
downloadgentoo-ff87051bd9066984b49c9b3b9bd65c4622f828de.tar.gz
gentoo-ff87051bd9066984b49c9b3b9bd65c4622f828de.tar.bz2
gentoo-ff87051bd9066984b49c9b3b9bd65c4622f828de.zip
dev-php/geos-php: Add extension split off from sci-libs/geos
The split was done upstream and includes PHP 7 support Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/geos-php/Manifest1
-rw-r--r--dev-php/geos-php/geos-php-1.0.0.ebuild30
-rw-r--r--dev-php/geos-php/metadata.xml8
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-php/geos-php/Manifest b/dev-php/geos-php/Manifest
new file mode 100644
index 000000000000..87ff289e412d
--- /dev/null
+++ b/dev-php/geos-php/Manifest
@@ -0,0 +1 @@
+DIST geos-php-1.0.0.tar.gz 40870 BLAKE2B c6d526470bdb7e4aecce6ce5f2132f90a6c40e5a2b3a8169bbb7ae101394340aad8a23309130c7f1421e19162b5559f9e87e58fb704e91b1fc03b612543551e8 SHA512 4ceb9e1152d0b534bc3a5e372be0b98770b1883ec4dda1177c9399d95d947b9feee412accf003d27b55b1a901c90259a9b38792b453dac11cb8af26af3cd91ec
diff --git a/dev-php/geos-php/geos-php-1.0.0.ebuild b/dev-php/geos-php/geos-php-1.0.0.ebuild
new file mode 100644
index 000000000000..848afdf5d7f0
--- /dev/null
+++ b/dev-php/geos-php/geos-php-1.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PHP_EXT_NAME="geos"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+S="${WORKDIR}/php-geos"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A PHP interface to GEOS - Geometry Engine, Open Source"
+HOMEPAGE="https://trac.osgeo.org/geos"
+SRC_URI="https://git.osgeo.org/gitea/geos/php-geos/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="sci-libs/geos[-php(-)]"
+DEPEND="sci-libs/geos[-php(-)] test? ( dev-php/phpunit )"
+DOCS=( README.md CREDITS NEWS TODO )
+PHP_EXT_ECONF_ARGS=()
diff --git a/dev-php/geos-php/metadata.xml b/dev-php/geos-php/metadata.xml
new file mode 100644
index 000000000000..b86acf66c756
--- /dev/null
+++ b/dev-php/geos-php/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+</pkgmetadata>