summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-20 08:58:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-20 11:39:39 +0200
commit86dc966e7ebaddb140c1a0df7c3b32fc12789d51 (patch)
tree9b4f80dfe3880c138eca0a166d5b999a62f3e561 /dev-python/Faker
parentdev-python/notebook: Bump to 6.4.5 (diff)
downloadgentoo-86dc966e7ebaddb140c1a0df7c3b32fc12789d51.tar.gz
gentoo-86dc966e7ebaddb140c1a0df7c3b32fc12789d51.tar.bz2
gentoo-86dc966e7ebaddb140c1a0df7c3b32fc12789d51.zip
dev-python/Faker: Bump to 9.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Faker')
-rw-r--r--dev-python/Faker/Faker-9.5.0.ebuild29
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-9.5.0.ebuild b/dev-python/Faker/Faker-9.5.0.ebuild
new file mode 100644
index 000000000000..12e618b6e887
--- /dev/null
+++ b/dev-python/Faker/Faker-9.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="https://github.com/joke2k/faker"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/text-unidecode-1.3[${PYTHON_USEDEP}]
+ !dev-ruby/faker"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 68175ef85f8e..9cc2ad781d2c 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1 +1,2 @@
DIST Faker-9.3.1.tar.gz 1169930 BLAKE2B 464f092a5014ebfe2d6c1a83f8d30f13507835a35e8307a22accdd6da92dae02a541ae2f686d724686855ded7b7e0f3c1f3922de0040e22478d9b55b2833b84f SHA512 e7468b4d91b47ad22d300a37dfa21b91f354b46f845854a9fe8b40da61624dafea5fca4f519939fcc16a84e9d9d9f33f715dabf4e231b9950b4a5b3a37cfacd0
+DIST Faker-9.5.0.tar.gz 1176231 BLAKE2B 5b1fbdec6952ee18c4f7243e1776cc5b44b99b2120f9fe7dcf3ad6a633b46644645e5f836456a969b4861ab672f59ac4b14268bee55b0168a8cddbe96774f481 SHA512 a42a26583432f85466e5791a98ae91e168e2a3bbb04cc1fcd90c9c5d76d1d9e4de709852b832e1ebac01c365e7a6598e707cbf7c36799f97f080cb0ce3f60cdd