summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/Flask-KVSession
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/Flask-KVSession')
-rw-r--r--dev-python/Flask-KVSession/Flask-KVSession-0.6.1.ebuild28
-rw-r--r--dev-python/Flask-KVSession/Flask-KVSession-0.6.2.ebuild28
-rw-r--r--dev-python/Flask-KVSession/Manifest2
-rw-r--r--dev-python/Flask-KVSession/metadata.xml14
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/Flask-KVSession/Flask-KVSession-0.6.1.ebuild b/dev-python/Flask-KVSession/Flask-KVSession-0.6.1.ebuild
new file mode 100644
index 000000000000..2ce175e7c357
--- /dev/null
+++ b/dev-python/Flask-KVSession/Flask-KVSession-0.6.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Transparent server-side session support for flask"
+HOMEPAGE="https://pypi.python.org/pypi/Flask-KVSession https://github.com/mbr/flask-kvsession"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/flask-0.8[${PYTHON_USEDEP}]
+ >=dev-python/simplekv-0.9.1[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-0.20[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/Flask-KVSession/Flask-KVSession-0.6.2.ebuild b/dev-python/Flask-KVSession/Flask-KVSession-0.6.2.ebuild
new file mode 100644
index 000000000000..6eb4c965cd06
--- /dev/null
+++ b/dev-python/Flask-KVSession/Flask-KVSession-0.6.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Transparent server-side session support for flask"
+HOMEPAGE="https://pypi.python.org/pypi/Flask-KVSession https://github.com/mbr/flask-kvsession"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/flask-0.8[${PYTHON_USEDEP}]
+ >=dev-python/simplekv-0.9.1[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-0.20[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/Flask-KVSession/Manifest b/dev-python/Flask-KVSession/Manifest
new file mode 100644
index 000000000000..0482ceaa704a
--- /dev/null
+++ b/dev-python/Flask-KVSession/Manifest
@@ -0,0 +1,2 @@
+DIST Flask-KVSession-0.6.1.tar.gz 37725 SHA256 19a5d44aca843999f5f6f87a618dab44272db227a959867a4c6c64ae3a743a55 SHA512 a0de01d546996c0f09d1cfa2c537fb3868717bcfcdbd3f3f93c2102349bdd1e9fd00d1efcf1c3a80f9cddf173ed43781774e75c7cf1114a1aff549c1f98160da WHIRLPOOL 8f08cc60e26699352199fb479cc6eac7ac0c224d2cee5089dc2d45cfb29380842444bd90662175357f35ee0414c8d418d3c8f172ce303602499946250f80f3e4
+DIST Flask-KVSession-0.6.2.tar.gz 38037 SHA256 9c0ee93fae089c45baeda0a3fd3ae32a96ee81c34996017749f8b3fd06df936c SHA512 11cbb4ee74dc2a1b44dd1f91729dfb65fc9beb9d93c86ce06a861eba8bd87139897a9f6dca0b5f7f8249034b5eeb3c93327e956b4ea34cd409adfc889b75e33b WHIRLPOOL 2f1363edbb93fbbe33b4e1e08247a717ac45c4cad50554e8ecf824590376e77aa645cfb5e6e37d200cd561db69840d0f986797f519c74f4adf0dc562ea6db3ea
diff --git a/dev-python/Flask-KVSession/metadata.xml b/dev-python/Flask-KVSession/metadata.xml
new file mode 100644
index 000000000000..c4f1b66a1a32
--- /dev/null
+++ b/dev-python/Flask-KVSession/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ <description>Python team can take the package if they wish.</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">Flask-KVSession</remote-id>
+ <remote-id type="github">mbr/flask-kvsession</remote-id>
+ </upstream>
+</pkgmetadata>