summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-17 20:41:58 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-17 20:57:04 +0200
commit09a221199f010d05b9824c82202abd1aef866e99 (patch)
tree81846332eb6634270abc1addc83c0ad347f4b96a /dev-python/GitPython
parentdev-python/notebook: Bump to 7.0.6 (diff)
downloadgentoo-09a221199f010d05b9824c82202abd1aef866e99.tar.gz
gentoo-09a221199f010d05b9824c82202abd1aef866e99.tar.bz2
gentoo-09a221199f010d05b9824c82202abd1aef866e99.zip
dev-python/GitPython: Bump to 3.1.38
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/GitPython')
-rw-r--r--dev-python/GitPython/GitPython-3.1.38.ebuild84
-rw-r--r--dev-python/GitPython/Manifest2
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.38.ebuild b/dev-python/GitPython/GitPython-3.1.38.ebuild
new file mode 100644
index 000000000000..cc252e9af748
--- /dev/null
+++ b/dev-python/GitPython/GitPython-3.1.38.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+TEST_P=GitPython-${PV}
+GITDB_P=gitdb-4.0.10
+SMMAP_P=smmap-5.0.0_p1
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="
+ https://github.com/gitpython-developers/GitPython/
+ https://pypi.org/project/GitPython/
+"
+SRC_URI+="
+ test? (
+ https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
+ )
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "travis@ci.com" || die
+ git config --global user.name "Travis Runner" || die
+
+ git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
+ git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb || die
+ git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
+
+ cd "${T}"/test || die
+ git rev-parse HEAD > .git/refs/remotes/origin/master || die
+ TRAVIS=1 ./init-tests-after-clone.sh || die
+ cat test/fixtures/.gitconfig >> ~/.gitconfig || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # performance tests are unreliable by design
+ test/performance
+ # unimpoortant and problematic
+ test/test_installation.py
+ # Internet
+ test/test_repo.py::TestRepo::test_leaking_password_in_clone_logs
+ test/test_quick_doc.py::QuickDoc::test_cloned_repo_object
+ # requires which(1)
+ # https://github.com/gitpython-developers/GitPython/pull/1525
+ test/test_git.py::TestGit::test_refresh
+ # TODO
+ test/test_submodule.py::TestSubmodule::test_base_rw
+ test/test_submodule.py::TestSubmodule::test_git_submodules_and_add_sm_with_new_commit
+ test/test_submodule.py::TestSubmodule::test_list_only_valid_submodules
+ test/test_submodule.py::TestSubmodule::test_root_module
+ )
+
+ epytest -o addopts= test
+}
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index 70a5a1d65ca3..3ff48331f5b2 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -1,4 +1,6 @@
DIST GitPython-3.1.37.gitbundle 9744035 BLAKE2B 57f16e0ebfdf6e2078c8a8fa220185add124431491b0959649c5fca8cf234cf4f3bb86b46937a04de33b5600a3c50dc2c46acff69dfbb03973d48663f8a45bc8 SHA512 b18e2cc7f97f82ba7f36181bb76bb58797ac0c13043f44b9ffdb31523ffafd37cc916986a8a358c85c867937145ad58da052bf650fd346fdacc80b89feeb8d8c
DIST GitPython-3.1.37.tar.gz 200076 BLAKE2B b5db83f6712a94464fec98229af739ca7eb71eb47bd03164e94bb680c03bd84e49c7956e3a58937464c6fd6e4254a24d5e89150f40a59c5d101d7e56daca8fba SHA512 c036b5a12b2839a152d21cc6163445c067d70b18984888e799b0900449bea0a5290f6520fae5cab83fb8553af9c6bb0150c9b28103311deecb3686de30dd35f1
+DIST GitPython-3.1.38.gitbundle 9830368 BLAKE2B 4a0e5c9f7f859b49d36d8d8deef79aa59615698416586d2802d428d21b959bd80da78555588f51db4833f35e2cc63d56ef9188a59916693af484e6e6ccc4c6b9 SHA512 5fff695ac828bb0495fb8dd9bc75f57e44d721ad8010577d567c34638e75855d22ce6560649cebe26a84f1baa0f245b82b9369e19ce6e3af36eadcfd51049c23
+DIST GitPython-3.1.38.tar.gz 200632 BLAKE2B 56c9b0f96c70e9f021d9830b220a43902de58271c38b25886c93d33706bd5a4dd081ca3cc3c126c7d5da24ed715a36b570b7a81f9d71aa3c1bfc77f2f7865730 SHA512 39bdf3dc3b1b1467a6f5426817977a353d54d4798451126f847911039de84d7d8030bc4d4263fd7584685a5a8113fc62d29f6c98c0bc95b646ee4f2f0ef60862
DIST gitdb-4.0.10.gitbundle 1485461 BLAKE2B 5a217c609a402cd7888da1502b25d217812503cd703cda8bce3c7159732c59d7f4bcd52688a5da457f43fde1645a6db79588a6fc8cc8dff5c58e9dcbaef79b9a SHA512 98dba48f75e28eaded791f91c611e07bef73c28a7f8ac58889b05d04f4b3699a85a5be1c829ea3e2f380507a9009f35bc552bb4260564127e2863807f9b4712a
DIST smmap-5.0.0_p1.gitbundle 324544 BLAKE2B 69098c7644abaec7f32226cad7ff3008e49d94c9f7349d0b815223249c20bfd2b51a50474e51864821f30c98f5982e5c35ce9217145a1e5d11326492c41faecc SHA512 4f36ca2c94ddfeb949c880fb52c3b1905d144dd59b95f2f05c93ed7b694dcb128218a2800ca23b721fbeff9a1920e8c3326675098e2ef0361ff6e90c8c2850ba