summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-26 10:22:36 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-26 10:22:36 +0200
commit7d4548aeae1d768daa3b27b8bcceec9ecd580383 (patch)
tree41973ff8730925f50ffeb876fa9ddd236a6ae0a7 /dev-python/GitPython
parentdev-python/gast: Remove old (diff)
downloadgentoo-7d4548aeae1d768daa3b27b8bcceec9ecd580383.tar.gz
gentoo-7d4548aeae1d768daa3b27b8bcceec9ecd580383.tar.bz2
gentoo-7d4548aeae1d768daa3b27b8bcceec9ecd580383.zip
dev-python/GitPython: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/GitPython')
-rw-r--r--dev-python/GitPython/GitPython-3.1.18.ebuild66
-rw-r--r--dev-python/GitPython/GitPython-3.1.19.ebuild74
-rw-r--r--dev-python/GitPython/Manifest4
3 files changed, 0 insertions, 144 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.18.ebuild b/dev-python/GitPython/GitPython-3.1.18.ebuild
deleted file mode 100644
index 2b4965f449ee..000000000000
--- a/dev-python/GitPython/GitPython-3.1.18.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-TEST_P=GitPython-${PV}
-GITDB_P=gitdb-4.0.7
-SMMAP_P=smmap-4.0.0
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
- test? (
- https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
- )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- ' python3_7)"
-BDEPEND="
- test? (
- >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests unittest
-
-src_test() {
- git config --global user.email "travis@ci.com" || die
- git config --global user.name "Travis Runner" || die
-
- git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
- git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb || die
- git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
-
- cd "${T}"/test || die
- git rev-parse HEAD > .git/refs/remotes/origin/master || die
- TRAVIS=1 ./init-tests-after-clone.sh || die
- cat test/fixtures/.gitconfig >> ~/.gitconfig || die
- rm -r test/performance || die
- # tests requiring network access
- sed -i -e 's:test_fetch_error:_&:' test/test_remote.py || die
- sed -i -e 's:test_leaking_password_in_clone_logs:_&:' test/test_repo.py || die
- # TODO
- sed -e 's:test_root_module:_&:' \
- -e 's:test_base_rw:_&:' \
- -i test/test_submodule.py || die
- rm test/test_installation.py || die
-
- distutils-r1_src_test
-}
diff --git a/dev-python/GitPython/GitPython-3.1.19.ebuild b/dev-python/GitPython/GitPython-3.1.19.ebuild
deleted file mode 100644
index 87d5f7d31add..000000000000
--- a/dev-python/GitPython/GitPython-3.1.19.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-TEST_P=GitPython-${PV}
-GITDB_P=gitdb-4.0.7
-SMMAP_P=smmap-4.0.0
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
- test? (
- https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
- )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- ' python3_7)"
-BDEPEND="
- test? (
- >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_test() {
- git config --global user.email "travis@ci.com" || die
- git config --global user.name "Travis Runner" || die
-
- git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
- git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb || die
- git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
-
- cd "${T}"/test || die
- git rev-parse HEAD > .git/refs/remotes/origin/master || die
- TRAVIS=1 ./init-tests-after-clone.sh || die
- cat test/fixtures/.gitconfig >> ~/.gitconfig || die
- sed -i -e '/addopts/d' pyproject.toml || die
-
- distutils-r1_src_test
-}
-
-python_test() {
- local deselect=(
- # performance tests are unreliable by design
- test/performance
- # unimpoortant and problematic
- test/test_installation.py
- # Internet
- test/test_repo.py::TestRepo::test_leaking_password_in_clone_logs
- # TODO
- test/test_submodule.py::TestSubmodule::test_base_rw
- test/test_submodule.py::TestSubmodule::test_root_module
- )
-
- epytest ${deselect[@]/#/--deselect }
-}
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index 4ba6a31230df..39b46f53fe39 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -1,7 +1,3 @@
-DIST GitPython-3.1.18.gitbundle 9129652 BLAKE2B df2ea8fa06d4209c532a239fa5bebde29314b467811526f67629f181a62b2b5ba235a3302b979dfd87993deca238a91820b3caa58fcb7cf3aaffc3bf76b0c731 SHA512 91fd937193db8a948fb575bf24a295c349e69b132128ed3b0c4fc3be89feb76ff47f31afe422c99ccbee4cf908b3040e9dd3f568db74785d12cf6cabbc356daa
-DIST GitPython-3.1.18.tar.gz 181199 BLAKE2B ac50cee78b5980c6d23ec60786e8d279558a2740480e0975c212de8d96abd58da95de8d66bc9c7c3f0c7d1baa1757460f36df53552b06bd6323d3f882d0b90ae SHA512 981b3f4eec71c4e1de6efa2381c3c411aedfc51918f9f58f397926d21dabdfabb54d498ae44a5b6ceca59adf99e866df8d04f97a86df942e81408a5a0e751a15
-DIST GitPython-3.1.19.gitbundle 9507079 BLAKE2B 7f9304c45784ddb779642df6b4412d022dad5ee20f89e998281db426928ee7bfafadb9a849e174c7cf850b049697ac097e1d144ca40f86497c6bab03e32ede8b SHA512 1fa8b01b27a993221ba4771aca416c724c12c208169fe4a6e08666ebf20c8dd870eb01f039d33ed13d664df5c6126cc4477994092ceeea64fc77f28a68cd9279
-DIST GitPython-3.1.19.tar.gz 187639 BLAKE2B 835a43edc7adfbb6253abb904d2f313bb597418c749473e6ce5deef67e546ee5285146a3a8c34d6afc4f56345e3e6a6481899465c8598b5215dbadb59b0bd507 SHA512 019a558fbc60c540872451ae1cd5ab029d5b3c5d5ed4979dadaa0e1829548e04bba62173a85d8fceddab5a19bc83e1750d938f73e984a64747550e6936400c9e
DIST GitPython-3.1.20.gitbundle 9511740 BLAKE2B 17d1aeec50a85ff5b8688a984ff41933bc8a3d91ec2e706053fcaae9298d9d469b7c816ac61f82934d454f6ebacdbce4d56ac8936ba89a7a694b59cca8b9e821 SHA512 d49e429b45f9edbee9419b94136762a75cf33b1693f9f8fb809b0bf63f0a763d501d9ca42f332d156ba7d79d07eed310763af51797adec4dac30f7c073c415b2
DIST GitPython-3.1.20.tar.gz 188094 BLAKE2B 3741b6b2e6c77ea8464eb83abfc744e9c646d18368648f805a2aa2f6fdb1875ec61b7e4aa4e224a67bff49686268c86b2cd2b3faf19e9eaa4c9587aacb7fa3f4 SHA512 10dc9f154067eb79a98fbf3204e370e814ab00661ffd7c2e1a1dc8ba46475ed48ec8c355820deba609486c865301e13bd54797ab7da8fccf8cff9cc9efebb153
DIST gitdb-4.0.7.gitbundle 1498536 BLAKE2B 1e0aff67259c04d2932dbdefb0ae07bd9fb51c5dcb99ee8431e78bf428095250ed45f5e12e2484b407bb4257050b0864e67096b3501d4829491cb7714a7b5ddf SHA512 f8b1b3de00f0597d65f528dd30495fd3dd9e1e4d494987899ef2064d23947ede799db391a59688dfa27e4fcdc9379b5352a378b39e6fb2421e6c850f81157bec