summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-30 09:07:20 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-30 10:14:12 +0200
commit87c1218736147dc95359b6db3b78988c0fbdeb2d (patch)
tree7e7f8ebad1c996cdf98e37c4f72bdd513eaa686d /dev-python/MechanicalSoup
parentdev-python/astroid: Bump to 2.5.7 (diff)
downloadgentoo-87c1218736147dc95359b6db3b78988c0fbdeb2d.tar.gz
gentoo-87c1218736147dc95359b6db3b78988c0fbdeb2d.tar.bz2
gentoo-87c1218736147dc95359b6db3b78988c0fbdeb2d.zip
dev-python/MechanicalSoup: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/MechanicalSoup')
-rw-r--r--dev-python/MechanicalSoup/Manifest1
-rw-r--r--dev-python/MechanicalSoup/MechanicalSoup-1.1.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/MechanicalSoup/Manifest b/dev-python/MechanicalSoup/Manifest
index 3c645248837a..8d29a79d193b 100644
--- a/dev-python/MechanicalSoup/Manifest
+++ b/dev-python/MechanicalSoup/Manifest
@@ -1,2 +1,3 @@
DIST MechanicalSoup-0.12.0.tar.gz 44505 BLAKE2B 7c303f7ae4dea12157d5c845a4dcdc6923e76d3565debd88d2f43e2cfc29a503feb6accb969839a39b1c4071b029f53908a12902a5c4f175f0383da227224c55 SHA512 6cce80ea5a90e7f19f2b13749f6ee48222d973af66cb350ac867a554580b0d619defe5a93741e6ec8aa808c585a8c01703158c7484521ac069977388de8bb7e3
DIST MechanicalSoup-1.0.0.tar.gz 47572 BLAKE2B eace6cc4eaf50f01f8a7816d4d87a9345676b6921c8fe46b3280ac83463b241b2e6175b91ee1a5f907635c07ee8cf66324cb2e7938736b81e9a4f849f9159548 SHA512 00e2c5220c065b517301d9381a9bc5019f6f75dc5951a5ab4427fd7939b296b6b33a20b8f8a7e82c6feed2c9100e3481f38a424d63065883d71a6927119ad88c
+DIST MechanicalSoup-1.1.0.tar.gz 49270 BLAKE2B 947b35d819dc69508595adcfe5a0c8e6bd34888c995e9c3931613498ee1ca840ce16a14359aacbf9d40aa4f9ae59d45d14da5a150e3ce39ae7e72f587c94820e SHA512 26eaa54bcd1c0aac26504d7c482ed001830a1c79bf48a3055cef92348e9336887bef86cda68281911032159a3404a1f4ee8de9b6516d7d767cfd6b3b380c4ebe
diff --git a/dev-python/MechanicalSoup/MechanicalSoup-1.1.0.ebuild b/dev-python/MechanicalSoup/MechanicalSoup-1.1.0.ebuild
new file mode 100644
index 000000000000..c110cacf2a55
--- /dev/null
+++ b/dev-python/MechanicalSoup/MechanicalSoup-1.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python library for automating interaction with websites"
+HOMEPAGE="https://pypi.org/project/MechanicalSoup/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/beautifulsoup-4.7[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/requests-mock-1.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_prepare_all() {
+ # Override pytest options to skip coverage and flake8
+ sed -i -e '/^addopts =/d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}